aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-15 23:23:22 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:11 +0000
commit40cc3625500b3293e07fe529bf65a261f3067d74 (patch)
tree872e37ba448d09dde3b7734f0ba2835033f375c2 /gnu
parent4deb664c5df9f0dd64769777e85f3c76f2caae9b (diff)
downloadguix-40cc3625500b3293e07fe529bf65a261f3067d74.tar.gz
guix-40cc3625500b3293e07fe529bf65a261f3067d74.zip
gnu: python-pytest-cov: Update to 6.0.0.
* gnu/packages/check.scm (python-pytest-cov): Update to 6.0.0. [build-system]: Swap to pyproject-build-system. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I90f6eed232e0156d6d90b53ae87b423bad2f6f79
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 5c32b68af4..3b52c67e30 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1642,14 +1642,14 @@ following improvements:
(define-public python-pytest-cov
(package
(name "python-pytest-cov")
- (version "3.0.0")
+ (version "6.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-cov" version))
(sha256
- (base32 "0w6lfv8gc1lxmnvsz7mq5z9shxac5zz6s9mwrai108kxc6qzbw77"))))
- (build-system python-build-system)
+ (base32 "1h5dvj4lr0qpbxqd38g66ab7q41vbx30n0kgszibi2r4raavbq7x"))))
+ (build-system pyproject-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -1660,6 +1660,9 @@ following improvements:
;; with "Duplicate implicit target name".
(invoke "python" "./setup.py" "check"
"--strict" "--metadata"))))))
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
(propagated-inputs
(list python-coverage python-pytest))
(home-page "https://github.com/pytest-dev/pytest-cov")