aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-01-31 16:01:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-22 20:42:03 +0100
commit3ec74f9de94585f83ee8203e3022d036fe7bc0be (patch)
treea724d70c9783cc87e24b12694594d958ece1de34 /gnu
parent5508d9a8d7b29ac9a1398ba5a0423523477803b4 (diff)
downloadguix-3ec74f9de94585f83ee8203e3022d036fe7bc0be.tar.gz
guix-3ec74f9de94585f83ee8203e3022d036fe7bc0be.zip
gnu: Add r-fracdiff.
* gnu/packages/cran.scm (r-fracdiff): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b731ddc29e..71a7cc250e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19257,3 +19257,25 @@ are followed and which ones are not) from one package and use it to check
another. This makes it easier to find and correct the most important problems
first.")
(license license:gpl3)))
+
+(define-public r-fracdiff
+ (package
+ (name "r-fracdiff")
+ (version "1.5-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "fracdiff" version))
+ (sha256
+ (base32
+ "1dhfjlhr9sb38qgpsx0sm73l9lgc13d0fk32l7fmjfnalhr3n45q"))))
+ (properties `((upstream-name . "fracdiff")))
+ (build-system r-build-system)
+ (home-page "https://github.com/mmaechler/fracdiff")
+ (synopsis
+ "Fractionally differenced ARIMA aka ARFIMA(P,d,q) models")
+ (description
+ "This package provides tools for the maximum likelihood estimation of the
+parameters of a fractionally differenced ARIMA(p,d,q) model (Haslett and
+Raftery, Appl.Statistics, 1989); it includes inference and basic methods.")
+ (license license:gpl2+)))