aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author( <paren@disroot.org>2022-11-29 07:00:23 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2022-11-27 01:00:01 +0100
commit3e697f3642946b760541864d7a07ea1459378b53 (patch)
treeb0543daa4a3915083d49f068a67151278a23e283 /gnu
parent36a51e1dde13969aa357e23f289715b887903ed1 (diff)
downloadguix-3e697f3642946b760541864d7a07ea1459378b53.tar.gz
guix-3e697f3642946b760541864d7a07ea1459378b53.zip
gnu: Add rust-askama-0.11.
* gnu/packages/crates-io.scm (rust-askama-0.11): New variable. (rust-askama-0.10): Inherit from RUST-ASKAMA-0.11. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm49
1 files changed, 33 insertions, 16 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4e3f73fac6..e57e68a156 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -3663,35 +3663,52 @@ Askama.")
("rust-proc-macro2" ,rust-proc-macro2-1)
("rust-syn" ,rust-syn-1))))))
-(define-public rust-askama-0.10
+(define-public rust-askama-0.11
(package
(name "rust-askama")
- (version "0.10.5")
+ (version "0.11.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "askama" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32
- "0d1iwywdgw3nba2iphayw8sfm3s8m9izwnhfar707qa7ds5p766j"))))
+ (base32 "0f81mzccdadryzaf2dbad1araq4nadp9mssyvdvv31hj6w7z367v"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-askama-derive" ,rust-askama-derive-0.10)
- ("rust-askama-escape" ,rust-askama-escape-0.10)
- ("rust-askama-shared" ,rust-askama-shared-0.11)
- ("rust-mime" ,rust-mime-0.3)
- ("rust-mime-guess" ,rust-mime-guess-2))))
+ (list #:skip-build? #t
+ #:cargo-inputs
+ `(("rust-askama-derive" ,rust-askama-derive-0.11)
+ ("rust-askama-escape" ,rust-askama-escape-0.10)
+ ("rust-askama-shared" ,rust-askama-shared-0.12))))
(home-page "https://github.com/djc/askama")
- (synopsis
- "Type-safe, compiled Jinja-like templates for Rust")
+ (synopsis "Type-safe, compiled Jinja-like templates for Rust")
(description
- "This package provides a type-safe, compiled Jinja-like templates for Rust.")
+ "This package provides a type-safe, compiled Jinja-like template
+library for Rust.")
(license (list license:expat license:asl2.0))))
+(define-public rust-askama-0.10
+ (package
+ (inherit rust-askama-0.11)
+ (name "rust-askama")
+ (version "0.10.5")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "askama" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0d1iwywdgw3nba2iphayw8sfm3s8m9izwnhfar707qa7ds5p766j"))))
+ (arguments
+ (list #:skip-build? #t
+ #:cargo-inputs
+ `(("rust-askama-derive" ,rust-askama-derive-0.10)
+ ("rust-askama-escape" ,rust-askama-escape-0.10)
+ ("rust-askama-shared" ,rust-askama-shared-0.11)
+ ("rust-mime" ,rust-mime-0.3)
+ ("rust-mime-guess" ,rust-mime-guess-2))))))
+
(define-public rust-asn1-derive-0.8
(package
(name "rust-asn1-derive")