aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-17 00:13:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:19 +0200
commit3d6607d5182354158cd8cc09077bfbb78baff438 (patch)
treec8ecb8213f2fe7938be1a743348c684f67ca8b09 /gnu
parent176f5439fba5f90505810c4ef9abd379e9895e4d (diff)
downloadguix-3d6607d5182354158cd8cc09077bfbb78baff438.tar.gz
guix-3d6607d5182354158cd8cc09077bfbb78baff438.zip
gnu: texlive-tex-gyre: Refresh package definition.
* gnu/packages/tex.scm (texlive-tex-gyre): Remove SIMPLE-TEXLIVE-PACKAGE call. [propagated-inputs]: Add TEXLIVE-KVOPTIONS.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm31
1 files changed, 18 insertions, 13 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 43156bf7f2..53241ad941 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1338,19 +1338,24 @@ font from Adobe's basic set.")
(define-public texlive-tex-gyre
(package
- (inherit (simple-texlive-package
- "texlive-tex-gyre"
- '("/doc/fonts/tex-gyre/GUST-FONT-LICENSE.txt"
- "/fonts/afm/public/tex-gyre/"
- "/fonts/enc/dvips/tex-gyre/"
- "/fonts/map/dvips/tex-gyre/"
- "/fonts/opentype/public/tex-gyre/"
- "/fonts/tfm/public/tex-gyre/"
- "/fonts/type1/public/tex-gyre/"
- "/tex/latex/tex-gyre/")
- (base32
- "1ldnlmclghm3gnyv02r8a6cqybygz2ifq07mhykhf43h1pw3aq7k")
- #:trivial? #t))
+ (name "texlive-tex-gyre")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/tex-gyre/"
+ "fonts/afm/public/tex-gyre/"
+ "fonts/enc/dvips/tex-gyre/"
+ "fonts/map/dvips/tex-gyre/"
+ "fonts/opentype/public/tex-gyre/"
+ "fonts/tfm/public/tex-gyre/"
+ "fonts/type1/public/tex-gyre/"
+ "source/fonts/tex-gyre/"
+ "tex/latex/tex-gyre/")
+ (base32
+ "0229aa7cgw614zlc2n589fi4hfdfnv7dd83f5mfa358zdb8iw54j")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs (list texlive-kvoptions))
(home-page "https://ctan.org/pkg/tex-gyre")
(synopsis "TeX fonts extending URW fonts")
(description