aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:43:34 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:01 +0200
commit3d5d0eb44f7e4cc96d0fab585e9cc581d518f402 (patch)
tree914273fb2a42083ee6f9469b22f7dae0f1ebe02d /gnu
parent7db6b07aa3a5729c926ccc3c6bbc168679d8289e (diff)
downloadguix-3d5d0eb44f7e4cc96d0fab585e9cc581d518f402.tar.gz
guix-3d5d0eb44f7e4cc96d0fab585e9cc581d518f402.zip
gnu: Add texlive-tikzfill.
* gnu/packages/tex.scm (texlive-tikzfill): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 501cbf9a38..23ead1e0a5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4971,6 +4971,26 @@ graphic programming languages like Scratch, NEPO or PXT.")
"The package is a LaTeX package for ducks to be used in TikZ pictures.")
(license license:lppl1.3c)))
+(define-public texlive-tikzfill
+ (package
+ (name "texlive-tikzfill")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/tikzfill/" "tex/latex/tikzfill/")
+ (base32
+ "0n2hnnw4ffafwd9yy6pzcv0pc580y28dvz93g4hbi25dz32sawmk")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/tikzfill")
+ (synopsis "TikZ libraries for filling with images and patterns")
+ (description
+ "This is a collection of TikZ libraries which add further options to fill
+TikZ paths with images and patterns. The libraries comprise fillings with
+images from files and from TikZ pictures. Also, patterns of hexagons and of
+rhombi are provided.")
+ (license license:lppl1.3+)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")