aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-09 14:01:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-16 12:44:36 +0100
commit3d3a55ec19093784fa035de53b8ad9147a94d5c7 (patch)
treea3ace301033769583faed254f9238d48746d7824 /gnu
parent3a58a3ef053558bf229530c1792de23ef2651c44 (diff)
downloadguix-3d3a55ec19093784fa035de53b8ad9147a94d5c7.tar.gz
guix-3d3a55ec19093784fa035de53b8ad9147a94d5c7.zip
gnu: python-plastid: Update to 0.6.1.
* gnu/packages/bioinformatics.scm (python-plastid): Update to 0.6.1. [arguments]: Disable four tests. Change-Id: If0225f226e702e89d451e2955d0f76691a8816c0
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8ae2b249a9..5d0c53d45e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4014,19 +4014,27 @@ UCSC genome browser.")
(define-public python-plastid
(package
(name "python-plastid")
- (version "0.6.0")
+ (version "0.6.1")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/joshuagryphon/plastid")
- (commit (string-append "v" version))))
+ (commit "d97f239d73b3a7c2eff46f71928b777431891f90")))
(file-name (git-file-name name version))
(sha256
(base32
- "1ka9j08j6i105l89w8b7sg0l8lm3lcrxzy4cjl5dp4cxdmycap62"))))
+ "0iccpywlpf1ws46279z9rl0l29pil0rj0g2j5nvqq7jfbnq581cf"))))
(build-system pyproject-build-system)
(arguments
(list
+ #:test-flags
+ '(list "plastid/test"
+ ;; These four failures look like errors in the test wrapper
+ ;; class.
+ "-k" (string-append "not test_chrom_sizes"
+ " and not test_no_crash_if_file_not_exist"
+ " and not test_fiveprime_variable"
+ " and not test_fiveprime_variable_from_file"))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'unpack-test-data