aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 11:50:22 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:07 +0000
commit3b996e64f4617e188bb2b2e26ff3472940c39eb4 (patch)
treee161f7b27974dfa232286f2d7b1ebca6f093bc3a /gnu
parent34c0813aba88feb348db5f2ba34c64b948638ba7 (diff)
downloadguix-3b996e64f4617e188bb2b2e26ff3472940c39eb4.tar.gz
guix-3b996e64f4617e188bb2b2e26ff3472940c39eb4.zip
gnu: beets: Update to 2.0.0.
* gnu/packages/music.scm (beets): Update to 2.0.0. [native-inputs]: Add python-pytest-cov, python-setuptools, and python-wheel. Change-Id: I7e489acc875337f7c624b6ac24b27012a7bc200a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 74b2073965..77420de214 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4227,14 +4227,14 @@ websites such as Libre.fm.")
(define-public beets
(package
(name "beets")
- (version "1.6.0")
+ (version "2.0.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "beets" version))
(sha256
(base32
- "0paj2nxvdx4zz9xawjpbsh0dy1kp9kfhxg8akh1rpz2awhsbfvxa"))))
- (build-system python-build-system)
+ "1kzqn6f3iw30lav9cwf653w2ns1n09yrys54dqxf6a9ppjsp449v"))))
+ (build-system pyproject-build-system)
(arguments
(list
#:phases
@@ -4242,10 +4242,6 @@ websites such as Libre.fm.")
(add-after 'unpack 'set-HOME
(lambda _
(setenv "HOME" (string-append (getcwd) "/tmp"))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-v" "test"))))
;; Wrap the executable, so it can find python-gi (aka
;; pygobject) and gstreamer plugins.
(add-after 'wrap 'wrap-typelib
@@ -4262,7 +4258,10 @@ websites such as Libre.fm.")
python-mock
python-py7zr
python-pytest
- python-responses))
+ python-pytest-cov
+ python-setuptools
+ python-responses
+ python-wheel))
(inputs
(list bash-minimal
gst-plugins-base