aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2024-10-02 20:27:55 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:04:51 +0200
commit3ac90bdcf50f1df7ac091d70075e949dcc84b092 (patch)
tree1ee8b72adb5f0a9c905acb1ddbe569bed4fffc48 /gnu
parent376e0ce8364e0f0c171b950c13f5ac4ea57e4c93 (diff)
downloadguix-3ac90bdcf50f1df7ac091d70075e949dcc84b092.tar.gz
guix-3ac90bdcf50f1df7ac091d70075e949dcc84b092.zip
gnu: Add rust-gix-commitgraph-0.24.
gnu/packages/crates-vcs.scm(rust-gix-commitgraph-0.24): New variable. (rust-gix-commitgraph-0.23): Inherit from rust-gix-commitgraph-0.24. Change-Id: Ide39ab173cef8f6b16f3d9e1a41bd5e3a084b950
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-vcs.scm38
1 files changed, 31 insertions, 7 deletions
diff --git a/gnu/packages/crates-vcs.scm b/gnu/packages/crates-vcs.scm
index 54fe21e493..49f35ccdb3 100644
--- a/gnu/packages/crates-vcs.scm
+++ b/gnu/packages/crates-vcs.scm
@@ -1401,8 +1401,38 @@ command execution.")
`(#:tests? #f ; use of undeclared crate or module `gix_testtools`
#:cargo-inputs (("rust-bstr" ,rust-bstr-1))))))
+(define-public rust-gix-commitgraph-0.24
+ (package
+ (name "rust-gix-commitgraph")
+ (version "0.24.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "gix-commitgraph" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0y7wc0y0xb0kh3c22pj3ns04zdqglqb22gj71kn3cn2ngzv0cfqk"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-bstr" ,rust-bstr-1)
+ ("rust-document-features" ,rust-document-features-0.2)
+ ("rust-gix-chunk" ,rust-gix-chunk-0.4)
+ ("rust-gix-features" ,rust-gix-features-0.38)
+ ("rust-gix-hash" ,rust-gix-hash-0.14)
+ ("rust-memmap2" ,rust-memmap2-0.9)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-thiserror" ,rust-thiserror-1))))
+ (home-page "https://github.com/Byron/gitoxide")
+ (synopsis "Read only access to the Git commitgraph file format")
+ (description
+ "Part of the Gitoxide project, a pure Rust implementation of Git. This
+package provides read only access to Git's commitgraph file format.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-gix-commitgraph-0.23
(package
+ (inherit rust-gix-commitgraph-0.24)
(name "rust-gix-commitgraph")
(version "0.23.2")
(source
@@ -1412,7 +1442,6 @@ command execution.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "1z0hn19phbwcwmvp6mn21pvmlq92jyjzw19y0rvs87wm6kscp3by"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs (("rust-bstr" ,rust-bstr-1)
("rust-document-features" ,rust-document-features-0.2)
@@ -1421,12 +1450,7 @@ command execution.")
("rust-gix-hash" ,rust-gix-hash-0.14)
("rust-memmap2" ,rust-memmap2-0.9)
("rust-serde" ,rust-serde-1)
- ("rust-thiserror" ,rust-thiserror-1))))
- (home-page "https://github.com/Byron/gitoxide")
- (synopsis "Read only access to Git the commitgraph file format")
- (description "Part of Gitoxide, a pure Rust implementation of Git. This
-package provides read only access to git commitgraph file.")
- (license (list license:expat license:asl2.0))))
+ ("rust-thiserror" ,rust-thiserror-1))))))
(define-public rust-gix-commitgraph-0.22
(package