aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-06 11:55:53 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-06 12:22:16 +0100
commit38ec52136f48c8bdcb6622096f25812d5a507cf6 (patch)
tree57767552c4cd8bda7a3b8fd9415f134f48bb0b7a /gnu
parentc63566c5cfe622575637530227169f7d40c2422a (diff)
downloadguix-38ec52136f48c8bdcb6622096f25812d5a507cf6.tar.gz
guix-38ec52136f48c8bdcb6622096f25812d5a507cf6.zip
gnu: texlive-latex-kvoptions: Rename to texlive-kvoptions.
* gnu/packages/tex.scm (texlive-kvoptions): New variable. (texlive-latex-kvoptions): Deprecated alias. (texlive-hyperref): * gnu/packages/plotutils.scm (asymptote): Use new name.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/plotutils.scm2
-rw-r--r--gnu/packages/tex.scm60
2 files changed, 43 insertions, 19 deletions
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 26623bc487..564a68618b 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -302,7 +302,7 @@ colors, styles, options and details.")
texlive-latex-base
texlive-latex-geometry
texlive-graphics
- texlive-latex-kvoptions
+ texlive-kvoptions
texlive-latex-media9
texlive-oberdiek ;for ifluatex
texlive-latex-ocgx2
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 588d240947..c7f471b868 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3517,7 +3517,7 @@ XML, using UTF-8 or a suitable 8-bit encoding.")
texlive-pdfescape
texlive-auxhook
texlive-hycolor
- texlive-latex-kvoptions
+ texlive-kvoptions
texlive-letltxmacro
texlive-pdftexcmds
texlive-refcount
@@ -3584,7 +3584,7 @@ arrows; record information about document class(es) used; and many more.")
#:trivial? #t))
(propagated-inputs
(list texlive-atveryend texlive-infwarerr
- texlive-uniquecounter texlive-latex-kvoptions
+ texlive-uniquecounter texlive-kvoptions
texlive-pdftexcmds))
(home-page "https://www.ctan.org/pkg/rerunfilecheck")
(synopsis "Checksum based rerun checks on auxiliary files")
@@ -5939,23 +5939,47 @@ transliterate semitic languages; patches to make (La)TeX formulae embeddable
in SGML; use maths minus in text as appropriate; simple Young tableaux.")
(license license:gpl2)))
-(define-public texlive-latex-kvoptions
- (package
- (inherit (simple-texlive-package
- "texlive-latex-kvoptions"
- (list "/doc/latex/kvoptions/"
- "/tex/latex/kvoptions/")
- (base32
- "02i4n2n3j4lg68d3nam08m63kb4irc99wfhyc2z51r02lm1wwmvw")
- #:trivial? #t))
- (propagated-inputs
- (list texlive-kvsetkeys texlive-ltxcmds))
- (home-page "https://www.ctan.org/pkg/kvoptions")
- (synopsis "Key/value format for package options")
- (description
- "This package provides facilities for using key-value format in
+(define-public texlive-kvoptions
+ (let ((template (simple-texlive-package
+ "texlive-kvoptions"
+ (list "doc/latex/kvoptions/"
+ "source/latex/kvoptions/"
+ "tex/latex/kvoptions/")
+ (base32
+ "1b8q93l54160b8gn3fq484n15n6cylrhmf2xk7p42czg2rqw7w3l"))))
+ (package
+ (inherit template)
+ (outputs '("out" "doc"))
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ '())
+ "latex/kvoptions")
+ ((#:build-targets _ '())
+ #~(list "kvoptions.dtx"))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "source/latex/kvoptions")))
+ (replace 'copy-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((origin (assoc-ref inputs "source"))
+ (source (string-append #$output
+ "/share/texmf-dist/source"))
+ (doc (string-append #$output:doc
+ "/share/texmf-dist/doc")))
+ (copy-recursively (string-append origin "/source") source)
+ (copy-recursively (string-append origin "/doc") doc))))))))
+ (propagated-inputs
+ (list texlive-kvsetkeys texlive-ltxcmds))
+ (home-page "https://www.ctan.org/pkg/kvoptions")
+ (synopsis "Key/value format for package options")
+ (description
+ "This package provides facilities for using key-value format in
package options.")
- (license license:lppl1.3c+)))
+ (license license:lppl1.3c+))))
+
+(define-deprecated-package texlive-latex-kvoptions texlive-kvoptions)
(define-public texlive-fonts-ec
(package