aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-10 11:45:59 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-09-10 11:45:59 +0300
commit387d7d718ab1191f357f586ef9b186873f32db77 (patch)
treefc83371cd22158547c7d120a8fef5994546decd1 /gnu
parent357effe1ee0df5125f96ff2dbeec581afd707da4 (diff)
downloadguix-387d7d718ab1191f357f586ef9b186873f32db77.tar.gz
guix-387d7d718ab1191f357f586ef9b186873f32db77.zip
gnu: systemc: Update to 3.0.0.
* gnu/packages/fpga.scm (systemc): Update to 3.0.0. [source]: Download using git-fetch. [build-system]: Switch to cmake-build-system. [arguments]: Remove configure-flags. Add test-target. Change-Id: Id5097a4fc8cd5f3c131990cf3596f5fd581be088
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fpga.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index ba0d169fbc..070caf284c 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2021 Andrew Miloradovsky <andrew@interpretmath.pw>
;;; Copyright © 2022 Christian Gelinek <cgelinek@radlogic.com.au>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2024 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -467,18 +468,19 @@ a hardware description and verification language.")
(define-public systemc
(package
(name "systemc")
- (version "2.3.3")
+ (version "3.0.0")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://accellera.org/images/downloads/standards/"
- "systemc/systemc-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/accellera-official/systemc")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0gvv3xmhiwx1izmzy06yslzqzh6ygrgmw53xqfmyvbz5a6ivk0ap"))))
+ (base32 "1v5fg3h9ffdzq9f6zplvr9all00ssc1gpdvbg129xahkrbl53kvw"))))
(native-inputs (list perl))
- (build-system gnu-build-system)
- (arguments '(#:configure-flags '("--enable-debug")))
+ (build-system cmake-build-system)
+ (arguments '(#:test-target "check"))
(home-page "https://accellera.org/community/systemc")
(synopsis "Library for event-driven simulation")
(description