aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:02:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:41 +0200
commit3853487f9133c1ef36e04d331e337af88dead2a6 (patch)
treeb63176f0ad90ddeace89f27260604e00c49ac4c0 /gnu
parent78e7c677f471b734260e28d733eb8805e1fb2c1c (diff)
downloadguix-3853487f9133c1ef36e04d331e337af88dead2a6.tar.gz
guix-3853487f9133c1ef36e04d331e337af88dead2a6.zip
gnu: Add texlive-pwebmac.
* gnu/packages/tex.scm (texlive-pwebmac): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ab8a95f065..cb35848b9b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3501,6 +3501,42 @@ not overly complex, so that users should find it easy to adapt the macros to
their specific needs.")
(license license:lppl)))
+(define-public texlive-pwebmac
+ (package
+ (name "texlive-pwebmac")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/plain/pwebmac/" "tex/plain/pwebmac/")
+ (base32
+ "18mc66iv5jszxwnrwvlx2c040521mray480my9pdcl7aw5w2z4a2")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pwebmac")
+ (synopsis "Consolidated WEB macros for DVI and PDF output")
+ (description
+ "The original WEB system by Donald Knuth has the macros webmac.tex that
+produce DVI output only; for historic reasons, it will never be
+modified (apart from catastrophic errors). Han The Thanh has modified these
+macros in his @file{pdfwebmac.tex} for PDF output (only) with pdfTeX.
+Jonathan Kew's XeTeX has similar macros @file{xewebmac.tex} by Khaled Hosny
+that modify @file{webmac.tex} for PDF output; these macros can only be used
+with a specific TeX engine each. The present @code{pwebmac} package
+integrates these three WEB macro files similar to @file{cwebmac.tex} in Silvio
+Levy's and Don Knuth's CWEB system, so @file{pwebmac.tex} can be used with
+Plain TeX, pdfTeX, and XeTeX alike.
+
+Its initial application is the production of PDF and HINT files for all major
+WEB programs for TeX and friends. For this purpose, the shell script
+@command{makeall} was whipped together; it provides various command line
+options and works around several quirks in the WEB sources.
+
+WEB programmers who want to use @file{pwebmac.tex} instead of the default
+@file{webmac.tex} in their programs have to change the first line in the TeX
+file created by @code{weave}. From there, all depends on the TeX engine you
+use.")
+ (license license:public-domain)))
+
(define-public texlive-tex
(package
(name "texlive-tex")