aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2016-09-10 23:13:32 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-09-11 10:01:18 +0300
commit381000d794e970446a52b1ce2d4b79bc63e06f7b (patch)
treea2752a960400c5b55ad1dcb8432a1a7a974956e4 /gnu
parent90d8ef6bcb2b1216458ba7a99bb33947538e4461 (diff)
downloadguix-381000d794e970446a52b1ce2d4b79bc63e06f7b.tar.gz
guix-381000d794e970446a52b1ce2d4b79bc63e06f7b.zip
gnu: python-git-review: Wrap it so 'git', 'ssh' and 'scp' are found.
* gnu/packages/openstack.scm (python-git-review)[arguments]: Add 'wrap-program' phase. [inputs]: Add openssh. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/openstack.scm19
1 files changed, 17 insertions, 2 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 4cb38a9fc8..62f1e84a3b 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -20,6 +20,7 @@
(define-module (gnu packages openstack)
#:use-module (gnu packages python)
+ #:use-module (gnu packages ssh)
#:use-module (gnu packages tls)
#:use-module (gnu packages version-control)
#:use-module (guix build-system python)
@@ -796,12 +797,26 @@ permanence.")
(base32
"07d1jn9ryff5j5ic6qj5pbk10m1ccmpllj0wyalrcms1q9yhlzh8"))))
(build-system python-build-system)
- (arguments `(#:tests? #f)) ; tests require a running Gerrit server
+ (arguments
+ '(#:tests? #f ; tests require a running Gerrit server
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (git (assoc-ref inputs "git"))
+ (openssh (assoc-ref inputs "openssh")))
+ (wrap-program (string-append out "/bin/git-review")
+ `("PATH" ":" prefix
+ ,(map (lambda (dir)
+ (string-append dir "/bin"))
+ (list git openssh))))))))))
(native-inputs
`(("python-pbr" ,python-pbr)))
(inputs
`(("python-requests" ,python-requests)
- ("git" ,git)))
+ ("git" ,git)
+ ("openssh" ,openssh)))
(home-page "http://docs.openstack.org/infra/git-review/")
(synopsis "Command-line tool for Gerrit")
(description
lass='msg-avail'>...Fixes <https://bugs.gnu.org/40839>. Reported by Jan (janneke) Nieuwenhuizen <janneke@gnu.org> Fix suggested by Mathieu Othacehe <m.othacehe@gmail.com> However, <https://bugs.gnu.org/29296> still applies; %current-target-system may not be bound. * gnu/services/shepherd.scm (scm->go): Use `with-target' when cross-compiling. Jan (janneke) Nieuwenhuizen 2020-04-21gnu: shepherd: Update to 0.8.0....* gnu/packages/admin.scm (shepherd): Update to 0.8.0. * gnu/services/shepherd.scm (shepherd-configuration-file): Use 'default-pid-file-timeout' instead of fiddling with '%pid-file-timeout'. Ludovic Courtès 2020-04-17services: Move 'user-processes' to (gnu services shepherd)....* gnu/services/base.scm (%do-not-kill-file) (user-processes-shepherd-service, user-processes-service-type): Move to... * gnu/services/shepherd.scm: ... here. Ludovic Courtès 2020-04-15services: shepherd: Increase the PID file timeout to 30s....When running the installation image off a DVD, early I/O operations are extremely slow, to the point that something like dbus-daemon would need ~20s to start. This change works around the issue. Fixes <https://bugs.gnu.org/40572>. Reported by Florian Pelz <pelzflorian@pelzflorian.de>. * gnu/services/shepherd.scm (shepherd-configuration-file): Set %pid-file-timeout to 30. Ludovic Courtès 2020-03-29services: shepherd: Mark '.go' derivations as non-substitutable....* gnu/services/shepherd.scm (scm->go): Pass #:options to 'computed-file'. Ludovic Courtès 2020-02-16services: shepherd: Spawn services with nothing but the PATH variable....Previously, services spawned with 'make-forkexec-constructor' & co. would all inherit the environment variables of PID 1, which includes things like 'BOOT_IMAGE'. This change resets it to the bare minimum. * gnu/services/shepherd.scm (shepherd-configuration-file): Add call to 'default-environment-variables'. Remove 'setenv' call. Ludovic Courtès