aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSughosha <sughosha@disroot.org>2024-11-01 20:44:59 +0530
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-11-06 19:38:25 +0800
commit37a5ef4095a20d41c23c28ddcd600814452777ee (patch)
tree56fa4d25f71d67074828946f1ac405eed886c4e3 /gnu
parent57fb43e17daaa078c9f5eb5b572552ab5656b3aa (diff)
downloadguix-37a5ef4095a20d41c23c28ddcd600814452777ee.tar.gz
guix-37a5ef4095a20d41c23c28ddcd600814452777ee.zip
gnu: Add knights.
* gnu/packages/kde-games.scm (knights): New variable. Change-Id: I86346750c28fefd5b2a02cbda8dcc458907766fa
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-games.scm60
1 files changed, 60 insertions, 0 deletions
diff --git a/gnu/packages/kde-games.scm b/gnu/packages/kde-games.scm
index 10c26e1d8e..75c6038189 100644
--- a/gnu/packages/kde-games.scm
+++ b/gnu/packages/kde-games.scm
@@ -1594,6 +1594,66 @@ control of the board by capturing or adding to one square.
This package is part of the KDE games module.")
(license (list license:gpl2+ license:fdl1.2+))))
+(define-public knights
+ (package
+ (name "knights")
+ (version "24.05.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/knights-" version ".tar.xz"))
+ (sha256
+ (base32 "19xsa79p0ad3cgm1zz2ykbm4487fyizshn7ir8f5azhkr1bi6l8k"))))
+ (build-system qt-build-system)
+ (arguments
+ (list #:qtbase qtbase))
+ (native-inputs
+ (list extra-cmake-modules kdoctools))
+ (inputs
+ (list kconfigwidgets
+ kcoreaddons
+ kcrash
+ kdbusaddons
+ ki18n
+ kio
+ kplotting
+ ksvg
+ ktextwidgets
+ kwallet
+ kxmlgui
+ libkdegames
+ libplasma
+ qtspeech
+ qtsvg))
+ (home-page "https://apps.kde.org/knights/")
+ (synopsis "Chess game")
+ (description "KNights is a chess game, featuring:
+
+@itemize
+@item local play between two players on the same computer
+@item play against any computer program that supports the XBoard protocol
+@item play on the Free Internet Chess Server (FICS)
+@item watching two computer engines play against each other
+@item support for legal move checking
+@item markers for possible moves, opponent’s last move and sources of check
+@item board borders and site notations
+@item complete time control, with Plasma-styled clocks
+@item several themes, with the possibility of downloading new ones from within
+ the program
+@item animated moves (configurable)
+@item views for playing on a chess server, including a seek graph, text
+ console, and chat widget
+@item option to undo and redo moves
+@item graphic interface for making and receiving offers from remote players
+@item support for the UCI protocol (used by Stockfish, Chessbase, and many
+ others)
+@item support for saving and loading Portable game notation (PGN) files
+@item use of Jovie, the KDE text-to-speak program, to speak opponent’s moves
+@item ability to control the program via a D-Bus interface
+@end itemize")
+ (license license:gpl2+)))
+
(define-public kde-games
(package
(name "kde-games")