aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 01:25:29 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:03 +0800
commit36daf506feda2a3351435cefdfb67e1f65fb6f66 (patch)
tree122903afa5d452d9d036ee33c9c604b4cfd5154b /gnu
parent0069f8c711edbd01d43a3fc1003633ea6e1b0e6f (diff)
downloadguix-36daf506feda2a3351435cefdfb67e1f65fb6f66.tar.gz
guix-36daf506feda2a3351435cefdfb67e1f65fb6f66.zip
gnu: kwallet: Update to 6.3.0.
* gnu/packages/kde-frameworks.scm (kwallet): Update to 6.3.0. [inputs]: Remove qca and qtbase-5; add qca-qt6 and qtbase. Change-Id: I831468b01f9e74097ac1d414089979d8aa0916a4
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-frameworks.scm20
1 files changed, 10 insertions, 10 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 05641440ad..fdaebad37b 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -3267,7 +3267,7 @@ It supports rich text as well as plain text.")
(define-public kwallet
(package
(name "kwallet")
- (version "5.114.0")
+ (version "6.3.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3276,16 +3276,16 @@ It supports rich text as well as plain text.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1cji8bvy5m77zljyrrgipsw8pxcds1sgikxlq3sdfxymcsw2wr36"))))
+ "1p9a5lwn4lpalxs6nj8fbcmmngcbgaj6s9n9vz56j26rlfzypdpd"))))
(build-system cmake-build-system)
(arguments
(list #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests? ;; Seems to require network.
- (invoke "ctest" "-E"
- "(fdo_secrets_test)")))))))
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? ;; Seems to require network.
+ (invoke "ctest" "-E"
+ "(fdo_secrets_test)")))))))
(native-inputs
(list extra-cmake-modules kdoctools))
(inputs
@@ -3306,8 +3306,8 @@ It supports rich text as well as plain text.")
libgcrypt
phonon
qgpgme
- qca
- qtbase-5))
+ qca-qt6
+ qtbase))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Safe desktop-wide storage for passwords")
(description "This framework contains an interface to KWallet, a safe