aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-31 03:49:48 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:53:58 +0200
commit353fea6ab71fbeaea1866101d0929bf58263b75d (patch)
tree49f67757c8a3eb88819454bf0e40767f01911ca8 /gnu
parent1acdb763a03ab062aa176b8aeb54dfe02a592097 (diff)
downloadguix-353fea6ab71fbeaea1866101d0929bf58263b75d.tar.gz
guix-353fea6ab71fbeaea1866101d0929bf58263b75d.zip
gnu: emacs-el-mock: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-el-mock)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ae120319dd..662d415946 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2106,13 +2106,13 @@ This package also includes relevant snippets for yasnippet.")
(version "1.25.1")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/rejeep/el-mock.el/"
- "archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rejeep/el-mock.el.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "16xw94n58xxn3zvgyj72bmzs0k5lkvswjmzs79ws9n7rzdivb38b"))))
+ (base32 "13mv1rhgkwiww2wh5w926jz7idppp492wir1vdl245c5x50dh4f7"))))
(build-system emacs-build-system)
(home-page "https://github.com/rejeep/el-mock.el")
(synopsis "Tiny mock and stub framework in Emacs Lisp")