aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-10-25 09:40:59 +0200
committerAndreas Enge <andreas@enge.fr>2024-10-28 10:41:27 +0100
commit351fdf69f737d09d24499d6c1ff70a2325fff0fa (patch)
tree1cca5cc5d0dbb834d0a0d2926767a11d8382f2b6 /gnu
parent5034f2d45c2a307ebaad6e99957f3b3a4d8cdd0a (diff)
downloadguix-351fdf69f737d09d24499d6c1ff70a2325fff0fa.tar.gz
guix-351fdf69f737d09d24499d6c1ff70a2325fff0fa.zip
gnu: postgresql: Deprecate unsupported versions.
Versions 10 and 11 are unsupported according to https://www.postgresql.org/support/versioning/ postgresql-10 also has a CVE. * doc/guix.texi: Change default value of postgresql-service-type's postgresql field. * gnu/packages/databases.scm (postresql-10, postgresql-11): Use define-deprecated/public to warn users. * gnu/services/databases.scm (postgresql-configuration): Change the default value of postgresql-configuration-postgresql. * gnu/tests/guix.scm (%guix-data-service-os): Change the default value of postgresql. Signed-off-by: Andreas Enge <andreas@enge.fr> Change-Id: Ie8744c8e1f246e9b45ff5e29d4e98214de3ca66a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/databases.scm5
-rw-r--r--gnu/services/databases.scm2
-rw-r--r--gnu/tests/guix.scm2
3 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 663ff8fd26..06158f19e7 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -170,6 +170,7 @@
#:use-module (gnu packages web)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
+ #:use-module (guix deprecation)
#:use-module (guix gexp)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -1375,7 +1376,7 @@ pictures, sounds, or video.")
(base32
"09f99rp5q1xp769r71if9ckb4cbm0nnx2xmy8b1bhcvd8hax9va2"))))))
-(define-public postgresql-11
+(define-deprecated/public postgresql-11 #f
(package
(inherit postgresql-13)
(name "postgresql")
@@ -1391,7 +1392,7 @@ pictures, sounds, or video.")
(modify-inputs (package-native-inputs postgresql-13)
(replace "docbook-xml" docbook-xml-4.2)))))
-(define-public postgresql-10
+(define-deprecated/public postgresql-10 #f
(package
(inherit postgresql-11)
(version "10.23")
diff --git a/gnu/services/databases.scm b/gnu/services/databases.scm
index fa332d7978..0933eb5e79 100644
--- a/gnu/services/databases.scm
+++ b/gnu/services/databases.scm
@@ -168,7 +168,7 @@ host all all ::1/128 md5"))
postgresql-configuration make-postgresql-configuration
postgresql-configuration?
(postgresql postgresql-configuration-postgresql ;file-like
- (default postgresql-10))
+ (default postgresql))
(port postgresql-configuration-port
(default 5432))
(locale postgresql-configuration-locale
diff --git a/gnu/tests/guix.scm b/gnu/tests/guix.scm
index 12ad1bf255..98afc4a350 100644
--- a/gnu/tests/guix.scm
+++ b/gnu/tests/guix.scm
@@ -158,7 +158,7 @@
(service dhcp-client-service-type)
(service postgresql-service-type
(postgresql-configuration
- (postgresql postgresql-10)
+ (postgresql postgresql)
(config-file
(postgresql-config-file
(hba-file