aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-26 18:16:58 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:28:37 +0000
commit337d2d0f9f36d9ff0fc6a2014f20738997f680ac (patch)
treee3ed899faa368b4cec0612a81c4566425054e5cd /gnu
parente28b014014909715236517857e8f8370548432de (diff)
downloadguix-337d2d0f9f36d9ff0fc6a2014f20738997f680ac.tar.gz
guix-337d2d0f9f36d9ff0fc6a2014f20738997f680ac.zip
gnu: python-a2wsgi: Update to 1.10.7.
* gnu/packages/python-web.scm (python-a2wsgi): Update to 1.10.7. [arguments]<tests>: Enable most of them. <test-flags>: Exclude test which introduce cycle. [native-inputs]: Add python-pytest, python-httpx-bootstrap, and python-pytest-asyncio. Change-Id: Id171de02323e0db99c86fb7297be424a5ddc1d3b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm26
1 files changed, 19 insertions, 7 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index ba235d3538..d46d16c91e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -835,20 +835,32 @@ ASGI server.")
(define-public python-a2wsgi
(package
(name "python-a2wsgi")
- (version "1.7.0")
+ (version "1.10.7")
(source (origin
(method url-fetch)
(uri (pypi-uri "a2wsgi" version))
(sha256
(base32
- "1cmsbgfg0vp8pwqz8nmkbmdi0axis1yl34qb280h5ssh08ngc1m9"))))
+ "13ikyfmkx7hlrbg5rpcdm6kw4wcsy00giil3f72hpb6sw7vjyinf"))))
(build-system pyproject-build-system)
(arguments
- (list #:build-backend "pdm.backend"
- ;; Tests have a circular dependency on uvicorn.
- #:tests? #f))
- (native-inputs
- (list python-pdm-backend))
+ (list
+ #:test-flags
+ #~(list "-k" (string-join
+ (list "not test_starlette_stream_response"
+ "test_starlette_base_http_middleware"
+ "test_baize_stream_response")
+ " and not "))
+ #:build-backend "pdm.backend"))
+ (native-inputs
+ (list python-pdm-backend
+ python-pytest
+ ;; python-baize ; not packed yet
+ python-httpx-bootstrap
+ ;; Cycle: python-a2wsgi->python-uvicorn->
+ ;; python-httpx->python-starlette->python-a2wsgi
+ ;; python-starlette
+ python-pytest-asyncio))
(home-page "https://github.com/abersheeran/a2wsgi")
(synopsis "Convert WSGI to ASGI or vice versa")
(description