aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-03 21:24:05 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:39 +0000
commit32853832d52e518e3dec9010da0db552c1fecdb9 (patch)
tree93c8d8f294e69ef76d4066f1e6980d373f43d61a /gnu
parent9a29c9e09eaf9cdb08504f43f8cbd9388972c019 (diff)
downloadguix-32853832d52e518e3dec9010da0db552c1fecdb9.tar.gz
guix-32853832d52e518e3dec9010da0db552c1fecdb9.zip
gnu: Add go-github-com-deckarep-golang-set-v2.
* gnu/packages/golang-xyz.scm (go-github-com-deckarep-golang-set-v2): New variable. Change-Id: I0e59fecfeba327c4f926c94b65f7bc8c42750fda
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 2d534b8dcd..a48eb810ac 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2003,6 +2003,29 @@ more complicated parallel cases.")
"Set is the set collection for the Go language.")
(license license:expat)))
+(define-public go-github-com-deckarep-golang-set-v2
+ (package
+ (inherit go-github-com-deckarep-golang-set)
+ (name "go-github-com-deckarep-golang-set-v2")
+ (version "2.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/deckarep/golang-set")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "11bvia6cflq46nzc2hfgikgxyck7wskyi0i7ksy9r0d41l4jh4l9"))))
+ (arguments
+ (list
+ #:import-path "github.com/deckarep/golang-set/v2"
+ #:unpack-path "github.com/deckarep/golang-set"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-elliotchance-orderedmap-v2))))
+
(define-public go-github-com-dennwc-varint
(package
(name "go-github-com-dennwc-varint")