aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 10:47:35 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:05 +0200
commit3251b54d522c541083034500c47834d8a2fa32b5 (patch)
treef3ef342dd516d3a96aff3b5b982b6853d6058139 /gnu
parent681513a2510cdacf4dead04f6fd69a532c57432d (diff)
downloadguix-3251b54d522c541083034500c47834d8a2fa32b5.tar.gz
guix-3251b54d522c541083034500c47834d8a2fa32b5.zip
gnu: Add texlive-tikzscale.
* gnu/packages/tex.scm (texlive-tikzscale): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5ec6e6a1bb..8f0df0db52 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5222,6 +5222,27 @@ TikZ for generating posters. Several formatting options are available, and
spacing and layout of the poster is to a large extent automated.")
(license license:lppl1.2+)))
+(define-public texlive-tikzscale
+ (package
+ (name "texlive-tikzscale")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/tikzscale/"
+ "source/latex/tikzscale/"
+ "tex/latex/tikzscale/")
+ (base32
+ "1iq7f9jnw86rhp7b3sim3z56ygj005zygzfc0bdnpmx5s4ds1gpv")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/tikzscale")
+ (synopsis "Resize pictures while respecting text size")
+ (description
+ "The package extends the @code{\\includegraphics} command to support
+@code{tikzpicture} environments. It allows scaling of TikZ images and
+PGFPlots to a given width or height without changing the text size.")
+ (license license:lppl1.3+)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")