aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-05 17:35:42 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:35 -0400
commit314444917bea8ba9fe62a4ab3dba2c64475117b1 (patch)
treedea9a6a328749cb5e24f253dbc0a9f592229ec9a /gnu
parentc20660827e0d6b854c6500e685889f7c3beba40b (diff)
downloadguix-314444917bea8ba9fe62a4ab3dba2c64475117b1.tar.gz
guix-314444917bea8ba9fe62a4ab3dba2c64475117b1.zip
gnu: gnome-calculator: Update to 42.2.
* gnu/packages/gnome.scm (gnome-calculator): Update to 42.2. [phases]{skip-gtk-update-icon-cache}: New phase. [native-inputs]: Remove gtk+:bin. [inputs]: Add gsettings-desktop-schemas-next and libadwaita.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9893aaf21e..8875f3c021 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10367,7 +10367,7 @@ handling the startup notification side.")
(define-public gnome-calculator
(package
(name "gnome-calculator")
- (version "41.0")
+ (version "42.2")
(source
(origin
(method url-fetch)
@@ -10376,12 +10376,17 @@ handling the startup notification side.")
name "-" version ".tar.xz"))
(sha256
(base32
- "16fwwfnw1w8p53ffny6zkff5cfsmg7xax9kmfgb7czjqv15w0vd6"))))
+ "1866qn0r9xp7b7j1436kry2k3bdh9ikhz2wm41jxcn1nljyb3nik"))))
(build-system meson-build-system)
(arguments
'(#:glib-or-gtk? #t
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
(add-before 'check 'pre-check
(lambda _
;; Tests require a writable HOME.
@@ -10389,14 +10394,14 @@ handling the startup notification side.")
(native-inputs
(list gettext-minimal
`(,glib "bin") ;for glib-compile-schemas, gio-2.0.
- `(,gtk+ "bin") ;for gtk-update-icon-cache
itstool
- vala
pkg-config
- python))
+ python
+ vala))
(inputs
- (list `(,glib "bin")
+ (list gsettings-desktop-schemas-next
gtksourceview
+ libadwaita
libgee
libhandy
libsoup-minimal-2