aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 23:56:12 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:18 +0200
commit2fe780d14dc79122e0d45aa1fe578794e38ad73c (patch)
tree951d9648ab0a3047340089fe00a56c97b08d2ccc /gnu
parent02277f9213b8ad25c9adccdfef9f246e09622eb0 (diff)
downloadguix-2fe780d14dc79122e0d45aa1fe578794e38ad73c.tar.gz
guix-2fe780d14dc79122e0d45aa1fe578794e38ad73c.zip
gnu: texlive-mkpattern: Refresh package definition.
* gnu/packages/tex.scm (texlive-mkpattern): Remove SIMPLE-TEXLIVE-PACKAGE call.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 14e24b3060..7f8822c0cf 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1811,22 +1811,22 @@ details can be found in the documentation.")
(define-public texlive-mkpattern
(package
- (inherit (simple-texlive-package
- "texlive-mkpattern"
- (list "/doc/plain/mkpattern/README"
- "/doc/plain/mkpattern/mkpatdoc.tex"
- "/doc/plain/mkpattern/mkpatter.pdf"
- "/doc/plain/mkpattern/mkpattern-exmpl.tex"
- "/tex/plain/mkpattern/mkpatter.tex")
- (base32
- "0sxnkbcc802jl3fj56x9hvg978bpv15lhrwj0aykb4syq29l47ga")
- #:trivial? #t))
+ (name "texlive-mkpattern")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/plain/mkpattern/" "tex/plain/mkpattern/")
+ (base32
+ "0sxnkbcc802jl3fj56x9hvg978bpv15lhrwj0aykb4syq29l47ga")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
(home-page "https://ctan.org/pkg/mkpattern")
(synopsis "Utility for making hyphenation patterns")
- (description "Mkpattern is a general purpose program for the generation of
-hyphenation patterns, with definition of letter sets and template-like
-constructions. It also provides an easy way to handle different input and
-output encodings, and features generation of clean UTF-8 patterns.")
+ (description
+ "Mkpattern is a general purpose program for the generation of hyphenation
+patterns, with definition of letter sets and template-like constructions. It
+also provides an easy way to handle different input and output encodings, and
+features generation of clean UTF-8 patterns.")
(license license:lppl)))
;; This provides etex.src which is needed to build various formats, including