aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-03 19:46:30 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:38 +0000
commit2f4175c16fc9e9da2de945e1d47004892db1696b (patch)
treea3ce879d8a85cf09dd6a5e0c7f612940bfb11237 /gnu
parent2c173a76e4ab38ed108b4491f535da5fd20e830e (diff)
downloadguix-2f4175c16fc9e9da2de945e1d47004892db1696b.tar.gz
guix-2f4175c16fc9e9da2de945e1d47004892db1696b.zip
gnu: go-github-com-gogs-chardet: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-gogs-chardet): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I88666bcaf2e8ea62274a0b01a5cf7247da160fa2
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm23
-rw-r--r--gnu/packages/golang.scm23
2 files changed, 23 insertions, 23 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 04f6f6bb9a..d7fd47b79c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3170,6 +3170,29 @@ non-blocking @code{TryLock} function to allow locking without blocking
execution.")
(license license:bsd-3)))
+(define-public go-github-com-gogs-chardet
+ (package
+ (name "go-github-com-gogs-chardet")
+ (version "0.0.0-20211120154057-b7413eaefb8f")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gogs/chardet")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "12j8q5wc9m4n51v2j2m40nahqdl9bh3hzpdp26clzq91kc2amiz0"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/gogs/chardet"))
+ (home-page "https://github.com/gogs/chardet")
+ (synopsis "Character set detection for Go")
+ (description
+ "The chardet package ports character set detection from ICU to Go.")
+ (license license:expat)))
+
(define-public go-github-com-google-renameio
(package
(name "go-github-com-google-renameio")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7e44ed05c4..66303459ab 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8178,29 +8178,6 @@ file into a Go http.CookieJar.")
array or reader.")
(license license:expat)))
-(define-public go-github-com-gogs-chardet
- (package
- (name "go-github-com-gogs-chardet")
- (version "0.0.0-20211120154057-b7413eaefb8f")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/gogs/chardet")
- (commit (go-version->git-ref version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "12j8q5wc9m4n51v2j2m40nahqdl9bh3hzpdp26clzq91kc2amiz0"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "github.com/gogs/chardet"))
- (home-page "https://github.com/gogs/chardet")
- (synopsis "Character set detection for Go")
- (description
- "The chardet package ports character set detection from
-ICU to Go.")
- (license license:expat)))
-
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar