aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-11-21 18:51:37 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-12-02 17:08:54 +0100
commit2f224cf1c6d4ec29e637c26772e0a2eb6587353f (patch)
tree3166db45dfc5dd29095718650cbc0e6f61d96ac4 /gnu
parent40dbdb2395469521139745f6e8b894e9da6d0626 (diff)
downloadguix-2f224cf1c6d4ec29e637c26772e0a2eb6587353f.tar.gz
guix-2f224cf1c6d4ec29e637c26772e0a2eb6587353f.zip
gnu: gnome-music: Update to 44.0.
When wrapping gnome-music, GST_PLUGIN_SYSTEM_PATH should not override the plugins installed by the user. * gnu/packages/gnome.scm (gnome-music): Update to 44.0. [#:phases]<wrap-gnome-music>: Update path wrapping. [inputs]: Add bash-minimal. Replace libsoup-minimal-2 with libsoup. Change-Id: I9b8ac5ee65618baafc760be8f7ab3132f4d53345 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6b68707b25..a19ce64876 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -887,7 +887,7 @@ cloud integration is offered through GNOME Online Accounts.")
(define-public gnome-music
(package
(name "gnome-music")
- (version "42.1")
+ (version "44.0")
(source
(origin
(method url-fetch)
@@ -897,7 +897,7 @@ cloud integration is offered through GNOME Online Accounts.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0w42xnp6xy3sfakb4s0wq7xfg7p507whz5gzss5b2mkbm2k7yx67"))))
+ "0l8xiw1nv8agskrpgiyr7kinna3gms1hv5d64hh4fqifaz4smlcv"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -920,7 +920,7 @@ cloud integration is offered through GNOME Online Accounts.")
(wrap-program (string-append out "/bin/gnome-music")
`("GI_TYPELIB_PATH" =
(,(getenv "GI_TYPELIB_PATH")))
- `("GST_PLUGIN_SYSTEM_PATH" =
+ `("GST_PLUGIN_SYSTEM_PATH" suffix
(,(getenv "GST_PLUGIN_SYSTEM_PATH")))
`("GRL_PLUGIN_PATH" =
(,(getenv "GRL_PLUGIN_PATH")))
@@ -934,7 +934,8 @@ cloud integration is offered through GNOME Online Accounts.")
itstool
pkg-config))
(inputs
- (list gnome-online-accounts
+ (list bash-minimal
+ gnome-online-accounts
grilo
grilo-plugins
gst-plugins-base
@@ -946,7 +947,7 @@ cloud integration is offered through GNOME Online Accounts.")
libadwaita
libdazzle
libmediaart
- libsoup-minimal-2
+ libsoup
python-pycairo
python-pygobject
python