aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2023-03-10 12:32:31 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-02 22:28:56 +0200
commit2cefa6d8355eb876fe2a76bc7acfe1851cf4395d (patch)
tree080287d3e754b9b09043a50df10ccc0468d14fb0 /gnu
parent54247aed0033cfd7c5428f120ce9beac069b63d9 (diff)
downloadguix-2cefa6d8355eb876fe2a76bc7acfe1851cf4395d.tar.gz
guix-2cefa6d8355eb876fe2a76bc7acfe1851cf4395d.zip
gnu: Add pdpmake.
* gnu/packages/build-tools.scm (pdpmake): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/build-tools.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 38ad13db1f..00a563160d 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -1019,3 +1019,38 @@ maintenance-related files, for convenience.")
#:version "2022-12-31"
#:commit "875461ffdf58ac04677957b4ae4160465b83b940"
#:hash (base32 "0bf7a6wdns9c5wwv60qfcn9llg0j6jz5ryd2qgsqqx2i6xkmp77c")))
+
+(define-public pdpmake
+ (package
+ (name "pdpmake")
+ (version "1.4.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rmyorston/pdpmake")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fjx5imd7s0h0yy8h2qc4vkdq7kxqcljnrw6h8n88720xha5z3cb"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:test-target "test"
+ #:parallel-tests? #f
+ #:make-flags
+ #~(list "DESTDIR=\"\""
+ (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://frippery.org/make/")
+ (synopsis "POSIX make")
+ (description
+ "This package contains an implementation of POSIX make. The default
+configuration enables extensions. Generally these extensions are compatible
+with GNU make.")
+ ;; pdpmake is distributed under the public domain, but the sources include
+ ;; tests under the GPL license version 2.
+ (license (list license:gpl2 license:public-domain))))