aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2024-10-02 08:49:35 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:04:48 +0200
commit2bc704ba201cdb67c0d96606fdc7e2029213094a (patch)
tree7a6c7415c62142f083852978f3ecfc4b2102ecf2 /gnu
parent95a9115d0f5ae1006276b49ad3142de314818e51 (diff)
downloadguix-2bc704ba201cdb67c0d96606fdc7e2029213094a.tar.gz
guix-2bc704ba201cdb67c0d96606fdc7e2029213094a.zip
gnu: Add rust-chrono-tz-0.9.
* gnu/packages/crates-io.scm (rust-chrono-tz-0.9): New variable (rust-chrono-tz-0.8): Inherit from rust-chrono-tz-0.9. Change-Id: Id0f22956bb81866cd7c2fb35e9ebf13c93ef577a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm35
1 files changed, 30 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ed323c21dd..a48ecc3222 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -12643,23 +12643,23 @@ Encoding Standard.")
Python @code{arrow.humanize}.")
(license (list license:expat license:asl2.0))))
-(define-public rust-chrono-tz-0.8
+(define-public rust-chrono-tz-0.9
(package
(name "rust-chrono-tz")
- (version "0.8.5")
+ (version "0.9.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "chrono-tz" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1dv0yqhr60wrhm4sdlralqw1jf5plcxc91q6v93hvamzk6gbgmwi"))))
+ (base32 "1fvicqrlmdsjkrgxr7bxfd62i9w2qi2b6iv4w85av5syvqlqnsck"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-arbitrary" ,rust-arbitrary-1)
("rust-chrono" ,rust-chrono-0.4)
- ("rust-chrono-tz-build" ,rust-chrono-tz-build-0.2)
+ ("rust-chrono-tz-build" ,rust-chrono-tz-build-0.3)
("rust-phf" ,rust-phf-0.11)
("rust-serde" ,rust-serde-1)
("rust-uncased" ,rust-uncased-0.9))
@@ -12667,12 +12667,37 @@ Python @code{arrow.humanize}.")
(("rust-chrono" ,rust-chrono-0.4)
("rust-serde-test" ,rust-serde-test-1))))
(home-page "https://github.com/chronotope/chrono-tz")
- (synopsis "TimeZone implementations for rust-chrono from the IANA database")
+ (synopsis "TimeZone implementations for chrono from the IANA database")
(description
"Chrono-TZ is a library that provides implementors of the TimeZone trait
for @code{rust-chrono}.")
(license (list license:expat license:asl2.0))))
+(define-public rust-chrono-tz-0.8
+ (package
+ (inherit rust-chrono-tz-0.9)
+ (name "rust-chrono-tz")
+ (version "0.8.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "chrono-tz" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1dv0yqhr60wrhm4sdlralqw1jf5plcxc91q6v93hvamzk6gbgmwi"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-arbitrary" ,rust-arbitrary-1)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-chrono-tz-build" ,rust-chrono-tz-build-0.2)
+ ("rust-phf" ,rust-phf-0.11)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-uncased" ,rust-uncased-0.9))
+ #:cargo-development-inputs
+ (("rust-chrono" ,rust-chrono-0.4)
+ ("rust-serde-test" ,rust-serde-test-1))))))
+
(define-public rust-chrono-tz-0.6
(package
(inherit rust-chrono-tz-0.8)