aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2024-11-08 15:26:17 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-11-11 12:58:00 +0100
commit2b781003a4372b793923de8b0f65815c4d5d75a7 (patch)
tree4a6b6a66a647f0f7e8db966ff478dcfd04d2653f /gnu
parent6e19a94d5a5abd414544cba017b66799a3674a5a (diff)
downloadguix-2b781003a4372b793923de8b0f65815c4d5d75a7.tar.gz
guix-2b781003a4372b793923de8b0f65815c4d5d75a7.zip
gnu: Add python-rangehttpserver.
* gnu/packages/python-web.scm (python-rangehttpserver): New variable. Change-Id: Ib37b29bedb468faf4da5ab5080106c54e50f52c7 Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d892e03c9d..7bbf05f368 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7145,6 +7145,28 @@ than 326,000 known user-agents. Users can pick a random one, or select one
based on filters.")
(license license:expat)))
+(define-public python-rangehttpserver
+ (package
+ (name "python-rangehttpserver")
+ (version "1.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/danvk/RangeHTTPServer")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dx533fsbq1mbz3by7qkm5bh2c253nwvm8214pqbwbfq07kqkwf2"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-coverage python-coveralls python-pytest))
+ (home-page "https://github.com/danvk/RangeHTTPServer")
+ (synopsis "SimpleHTTPServer with support for range requests")
+ (description
+ "This tool provides a simple HTTP server with support for Range
+requests.")
+ (license license:asl2.0)))
+
(define-public python-flask-restx
(package
(name "python-flask-restx")