aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorCharles <charles.b.jackson@protonmail.com>2022-10-18 23:04:24 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-10-22 10:41:09 +0200
commit2902def73e3d9d671099cbbea7fcc59b12c10ec8 (patch)
tree69dd8b8b204d2b3f43c40ed2e3160b41057ee187 /gnu
parent863c228bfd53aac478eee46f6ee54d87fee9d764 (diff)
downloadguix-2902def73e3d9d671099cbbea7fcc59b12c10ec8.tar.gz
guix-2902def73e3d9d671099cbbea7fcc59b12c10ec8.zip
gnu: gnome-shell-extension-blur-my-shell: Update to 44.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-blur-my-shell): Update to 44. [source]: Remove snippet to delete compiled schemas. [arguments]<#:install-plan>: Update accordingly. <#:phases>: Remove ‘cd-src’. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome-xyz.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 68166978a1..b7e10100fb 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -996,7 +996,7 @@ animation of closing windowed applications.")
(define-public gnome-shell-extension-blur-my-shell
(package
(name "gnome-shell-extension-blur-my-shell")
- (version "29")
+ (version "44")
(source
(origin
(method git-fetch)
@@ -1006,22 +1006,21 @@ animation of closing windowed applications.")
(file-name (git-file-name name version))
(sha256
(base32
- "13x7zgaj3dz7lypdv1bgmpmh0f2w53q567zxmhmqimi1gy5mjrvk"))
- (snippet
- '(begin (delete-file "src/schemas/gschemas.compiled")))))
+ "0h7yfvrrg5r821mzrp42c09jws06mw6v9avvkfykqj8n8qnslmyx"))))
(build-system copy-build-system)
(arguments
- `(#:install-plan
- '(("." ,(string-append
- "share/gnome-shell/extensions/"
- "blur-my-shell@aunetx")
- #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
- "\\.xml$" "\\.compiled$")))
+ '(#:install-plan
+ (let ((extension "share/gnome-shell/extensions/blur-my-shell@aunetx"))
+ `(("src/" ,extension)
+ ("resources/" ,extension
+ #:include-regexp ("\\.svg$" "\\.ui"))
+ ("." ,extension
+ #:exclude-regexp ("src/" "resources/")
+ #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
+ "\\.xml$" "\\.compiled$"))))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'cd-src
- (lambda _ (chdir "src")))
- (add-before 'install 'compile-schemas
+ (add-after 'unpack 'compile-schemas
(lambda _
(with-directory-excursion "schemas"
(invoke "glib-compile-schemas" ".")))))))
en Lepiller * doc/build.scm (%languages): Add 'fr' cookbook translation. 2021-03-24Merge remote-tracking branch 'origin/master' into core-updatesEfraim Flashner 2021-03-20doc: Remove the guile-lib/htmlprag-fixed package.Maxim Cournoyer This hotfix package is no longer necessary as the ability to parameterize the way htmlprag tokenizes HTML was added in guile-lib 0.2.7. * doc/build.scm (guile-lib/htmlprag-fixed): Remove variable. (html-manual-identifier-index): Replace guile-lib/htmlprag-fixed by guile-lib, and make set the %strict-tokenizer? parameter to #t. (syntax-highlighted-html): Likewise. 2021-01-29gnu: Replace all uses of texlive-union by texlive-updmap.cfg.Maxim Cournoyer * doc/build.scm (pdf-manual) Replace texlive-union by texlive-updmap.cfg. * gnu/packages/algebra.scm (pari-gp): Likewise. * gnu/packages/bioinformatics.scm (discrover, velvet): Likewise. * gnu/packages/chez.scm (chez-scheme, chez-web, chez-sockets): Likewise. * gnu/packages/docbook.scm (dblatex): Likewise. * gnu/packages/emacs-xyz.scm (emacs-auctex): Likewise. * gnu/packages/engineering.scm (fastcap): Likewise. * gnu/packages/guile-xyz.scm (emacsy, guile-cv): Likewise. * gnu/packages/lisp.scm (sbcl): Likewise. * gnu/packages/maths.scm (octave, hypre): Likewise. * gnu/packages/music.scm (lilypond): Likewise. * gnu/packages/plotutils.scm (asymptote): Likewise. * gnu/packages/python-xyz.scm (python-numpy-documentation) (python-matplotlib-documentation, python-ipython-documentation) (python-pypandoc): Likewise. * gnu/packages/radio.scm (gnuradio, libosmo-dsp): Likewise. * gnu/packages/scheme.scm (mit-scheme): Likewise. * gnu/packages/statistics.scm (r-with-tests): Likewise. * gnu/packages/tex.scm (simple-texlive-package) (texlive-xmltex, texlive-tiny, texlive-jadetex, teximpatient, lyx): Likewise. 2020-10-21doc: Cookbook links to /manual/devel, not /manual.Ludovic Courtès Since the Cookbook is built from the 'master' branch, it should point to the manual from that same branch. * doc/build.scm (guix-mono-node-indexes, guix-split-node-indexes): Link to /manual/devel when %MANUAL is not "guix". 2020-10-19doc: Produce stylable HTML for @deftp, @deffn, etc.Ludovic Courtès 'makeinfo --help' uses <strong> and <em> for those entries. Replace that with CSS classes. * doc/build.scm (html-manual-identifier-index)[build]: Adjust to handle rewritten forms of <dt> entries. * doc/build.scm (syntax-highlighted-html)[build][syntax-highlight]: Handle <dt> forms and replace them. [highlight-definition, space?]: New procedures. 2020-10-17doc: Generate cross-references in code snippets to the Guile manual.Ludovic Courtès Occurrences of 'list', 'cons', etc. in code snippets now link to the relevant section of the Guile manual. * doc/build.scm (guile-manual, %guile-manual-base-url) (guile-mono-node-indexes, guile-split-node-indexes): New variables. (for-all-languages, merge-index-alists): New procedures. <top level>: Rename 'mono-node-indexes' and 'split-node-indexes' to 'guix-mono-node-indexes' and 'guix-split-node-indexes' respectively. Add 'mono-node-indexes' and 'split-node-indexes' defined as calls to 'merge-index-alists'. 2020-10-17doc: Allow code snippets in the cookbook to link to the manual.Ludovic Courtès Until now, only code snippets in the manual itself would contain links to identifier definitions. Now snippets in the cookbook also link to definitions in the manual. * doc/build.scm (html-manual): Add #:mono-node-indexes and #:multi-node-indexes and pass it to 'syntax-highlighted-html'. (pdf+html-manual): Likewise, and pass it to 'html-manual'. <top level>: Factorize 'version' and 'source'. Define 'guix-manual', 'mono-node-indexes', and 'split-node-indexes'. Pass #:mono-node-indexes and #:split-node-indexes to 'pdf+html-manual'. 2020-10-17doc: Move manual index creation to a separate derivation.Ludovic Courtès * doc/build.scm (normalize-language-code, html-manual-identifier-index): New procedures. (syntax-highlighted-html): Add #:mono-node-indexes and #:split-node-indexes. [build](underscore-decode, anchor-id->key, collect-anchors): Remove. (language+node-anchors, mono-node-anchors, multi-node-anchors): New variables. Use them. 2020-10-17doc: Remove 'build.scm' from the source of the manual.Ludovic Courtès That way we no longer have to rebuild the whole manual when fiddling with 'build.scm'. * doc/build.scm <top level>: Define 'select?' and pass it to 'pdf+html-manual'. 2020-09-04doc: Syntax highlighting now handles @var within @lisp.Ludovic Courtès * doc/build.scm (syntax-highlighted-html)[build](concatenate-pieces): Handle @var{name}. 2020-05-25doc: Remove one use of 'file-append*'.Ludovic Courtès * doc/build.scm (texinfo-manual-source)[build]: Use 'file-append', not 'file-append*', for 'htmlxref.cnf', to ensure it has the right basename.