aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorguix-patches--- via <guix-patches@gnu.org>2024-08-26 08:20:45 +0200
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-08-28 13:04:20 +0800
commit2787fd81e314138c9d3d397dc2365cbf7ea7acf2 (patch)
treef3e89cc1876155434be95209c559ea9ff2da9f62 /gnu
parent18431cb5bae24e8d48e3ce8c3255a3cfefbfcccb (diff)
downloadguix-2787fd81e314138c9d3d397dc2365cbf7ea7acf2.tar.gz
guix-2787fd81e314138c9d3d397dc2365cbf7ea7acf2.zip
gnu: tio: Update to 3.6.
* gnu/packages/terminals.scm (tio): Update to 3.6. [source]: Switch to git-fetch. Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Change-Id: I4e9ed921bdb9b14bd45e6c5e3ad33cebb6577ab1
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/terminals.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 7b99b9672e..d68be35148 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1498,15 +1498,15 @@ terminal are replicated to the others.
(define-public tio
(package
(name "tio")
- (version "3.3")
+ (version "3.6")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/tio/tio/releases/download/v"
- version "/tio-" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tio/tio")
+ (commit (string-append "v" version))))
(sha256
- (base32 "13favpvl343nbc0h26snn53lddwbznvd106rvvinnc12x6r3arjh"))))
+ (base32 "050zm7nh9niag1amjql859cj3xc9gbidk3zz546h6fhhh3vykmfl"))))
(build-system meson-build-system)
(native-inputs (list pkg-config))
(inputs (list glib lua))