aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:07:37 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:42 +0200
commit25c3ac5b8ae2ac20fc9e6121a5765fac6057b05d (patch)
tree526e4e485a9b06b7511b1af80b67553c19789f9d /gnu
parent8ac86b913ca86fe2701218589455cb007b45eda4 (diff)
downloadguix-25c3ac5b8ae2ac20fc9e6121a5765fac6057b05d.tar.gz
guix-25c3ac5b8ae2ac20fc9e6121a5765fac6057b05d.zip
gnu: lightdm: Explicitely use a native 'bash' for 'wrap-program'.
Having to use a native bash for 'wrap-program' is fairly unusual, but here it is the right thing, as it is for the test suite only. Placate the 'wrapper-inputs' linter. Also, eventually we might consider letting 'wrap-program' bail out if no bash for the host is found, even when compiling natively. But that's for later. * gnu/packages/display-managers.scm (lightdm)[arguments]<#:phases>{pre-check}: Set #:sh argument of 'pre-check' Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: Icc60ef7ae24a9c5935d328ef72dd1779ef70b05f
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/display-managers.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/display-managers.scm b/gnu/packages/display-managers.scm
index eccf2e199e..7e9c9c6180 100644
--- a/gnu/packages/display-managers.scm
+++ b/gnu/packages/display-managers.scm
@@ -386,6 +386,7 @@ experience for your users, your family and yourself")
(add-before 'check 'pre-check
(lambda _
(wrap-program "tests/src/test-python-greeter"
+ #:sh (which "bash")
`("GUIX_PYTHONPATH" ":" prefix (,(getenv "GUIX_PYTHONPATH")))
`("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH"))))
;; Avoid printing locale warnings, which trip up the text