aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-11 22:04:06 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:22 +0000
commit236ce6591b118d198861de2ab7a570bfb83465ff (patch)
treeb07a1594946f90d68b9938d5092e9be943f54bcf /gnu
parent037fbad3e6844aca2371b234da6fb6a24bbae652 (diff)
downloadguix-236ce6591b118d198861de2ab7a570bfb83465ff.tar.gz
guix-236ce6591b118d198861de2ab7a570bfb83465ff.zip
gnu: python-py: Improve package style.
* gnu/packages/python-xyz.scm (python-py): Add maintenance note. [build-system]: Swap to pyproject-build-system. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I8e14c2607d186e689461882fe4ac1b7f4c7ce84c
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3186e88407..eec2d1e92d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5576,6 +5576,8 @@ port forwards using @acronym{UPnP, Universal Plug and Play}.")
(home-page "http://miniupnp.free.fr")
(license license:bsd-3)))
+;; NOTE: As taken from upstram: "this library is in maintenance mode and
+;; should not be used in new code."
(define-public python-py
(package
(name "python-py")
@@ -5587,15 +5589,13 @@ port forwards using @acronym{UPnP, Universal Plug and Play}.")
(sha256
(base32
"06c7m7sfcn7587xd4s2bng8m6q1gsfd3j93afhplfjq74r0mrisi"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- ;; FIXME: "ImportError: 'test' module incorrectly imported from
- ;; '/gnu/store/...-python-pytest-mimimal-3.0.5/lib/python3.5/site-packages'.
- ;; Expected '/tmp/guix-build-python-py-1.4.31.drv-0/py-1.4.31/py'.
- ;; Is this module globally installed?"
- '(#:tests? #f))
+ '(#:tests? #f)) ;cycle with python-pytest
(native-inputs
- (list python-setuptools-scm))
+ (list python-setuptools
+ python-setuptools-scm
+ python-wheel))
(home-page "https://github.com/pytest-dev/py")
(synopsis "Python library for parsing, I/O, instrospection, and logging")
(description