aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-03-14 11:03:06 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-02 22:28:55 +0200
commit21b7514f509a1f7364d1aad1f9c9a447b3fdbe92 (patch)
tree9a6bdbd2733d1a32a1cbdc5654ddc561e67f6ed2 /gnu
parenta2734a0a52a58bc5b0721864d541d9b6eb92b172 (diff)
downloadguix-21b7514f509a1f7364d1aad1f9c9a447b3fdbe92.tar.gz
guix-21b7514f509a1f7364d1aad1f9c9a447b3fdbe92.zip
gnu: Add python-treelib.
* gnu/packages/python-xyz.scm (python-treelib): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 69dadd83ce..756dd87721 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9453,6 +9453,24 @@ is a distinct layer on top of traitlets, so you can use traitlets in your code
without using the configuration machinery.")
(license license:bsd-3)))
+(define-public python-treelib
+ (package
+ (name "python-treelib")
+ (version "1.6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "treelib" version))
+ (sha256
+ (base32
+ "1247rv9fbb8pw3xbkbz04q3vnvvva3hcw002gp1clp5psargzgqw"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-future))
+ (home-page "https://github.com/caesar0301/treelib")
+ (synopsis "Implementation of a tree structure in Python")
+ (description
+ "This package provides a Python implementation of a tree structure.")
+ (license license:asl2.0)))
+
(define-public python-jupyter-core
(package
(name "python-jupyter-core")