aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-21 19:32:43 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-30 15:10:45 +0000
commit201a8cd67599ff06f1c7b3dbd0a0cdfddd2bf46c (patch)
treece7a4de93e3a4cc5364455f3b9884ca5f46eb256 /gnu
parentc9b72c4ff8aaaa81724f76f0891fd9b68cfffed4 (diff)
downloadguix-201a8cd67599ff06f1c7b3dbd0a0cdfddd2bf46c.tar.gz
guix-201a8cd67599ff06f1c7b3dbd0a0cdfddd2bf46c.zip
gnu: python-stsynphot: Update to 1.4.0.
* gnu/packages/astronomy.scm (python-stsynphot): Update to 1.4.0. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I9155f517358ecf651a47fe48a676202a2c19bb2f
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm38
1 files changed, 21 insertions, 17 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index da12d28269..7d2b176002 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -5211,13 +5211,13 @@ implementing calibration pipeline software.")
(define-public python-stsynphot
(package
(name "python-stsynphot")
- (version "1.3.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "stsynphot" version))
- (sha256
- (base32
- "15m3vy39mc7rh1mrxs8d2bs0bx5vv632m6wg8n15fqjzhadqy7j5"))))
+ (version "1.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "stsynphot" version))
+ (sha256
+ (base32 "02xaglg1kv3mk6gqjcs1283mmy9b42fgsga8g2z8768lkgwmmg9j"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -5226,16 +5226,20 @@ implementing calibration pipeline software.")
;; Failed to load Vega spectrum from
;; /grp/redcat/trds/calspec/alpha_lyr_stis_010.fits;
#:tests? #f))
- (propagated-inputs (list python-astropy
- python-beautifulsoup4
- python-matplotlib
- python-numpy
- python-scipy
- python-synphot))
- (native-inputs (list python-pytest
- python-pytest-astropy
- python-pytest-astropy-header
- python-setuptools-scm))
+ (native-inputs
+ (list python-pytest
+ python-pytest-astropy
+ python-pytest-astropy-header
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
+ (propagated-inputs
+ (list python-astropy
+ python-beautifulsoup4
+ python-matplotlib
+ python-numpy
+ python-scipy
+ python-synphot))
(home-page "https://github.com/spacetelescope/stsynphot_refactor")
(synopsis "Synthetic photometry using Astropy for HST and JWST")
(description