aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-08-14 23:22:47 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:46 +0200
commit1fce094bfbc4a25d01a64fd88bbd1125656d8112 (patch)
treed1fb526fdbd7f66380d007dd283dab54a1d230f8 /gnu
parentbd2406d9d518148b54a9c3878003dbe3323e15c7 (diff)
downloadguix-1fce094bfbc4a25d01a64fd88bbd1125656d8112.tar.gz
guix-1fce094bfbc4a25d01a64fd88bbd1125656d8112.zip
gnu: perl-boot0: Use gexps.
* gnu/packages/commencement.scm (perl-boot0)[arguments]: Use gexps. Change-Id: I5c6358ce09a42bfb702d91325efa3ca81fe5494a
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/commencement.scm42
1 files changed, 21 insertions, 21 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index b31f976900..62bb2d6c96 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2464,27 +2464,27 @@ exec " gcc "/bin/" program
(source (bootstrap-origin (package-source perl)))
(inputs (%boot0-inputs))
(arguments
- `(#:implicit-inputs? #f
- #:guile ,%bootstrap-guile
- #:validate-runpath? #f
-
- ;; At the very least, this must not depend on GCC & co.
- #:disallowed-references ,(list %bootstrap-binutils)
-
- ,@(substitute-keyword-arguments (package-arguments perl)
- ((#:phases phases)
- `(modify-phases ,phases
- ;; Pthread support is missing in the bootstrap compiler
- ;; (broken spec file), so disable it.
- (add-before 'configure 'disable-pthreads
- (lambda _
- (substitute* "Configure"
- (("^libswanted=(.*)pthread" _ before)
- (string-append "libswanted=" before)))))))
- ;; Do not configure with '-Dusethreads' since pthread
- ;; support is missing.
- ((#:configure-flags configure-flags)
- `(delete "-Dusethreads" ,configure-flags)))))))
+ (append (list #:implicit-inputs? #f
+ #:guile %bootstrap-guile
+ #:validate-runpath? #f
+
+ ;; At the very least, this must not depend on GCC & co.
+ #:disallowed-references (list %bootstrap-binutils))
+ (substitute-keyword-arguments (package-arguments perl)
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ ;; Pthread support is missing in the bootstrap compiler
+ ;; (broken spec file), so disable it.
+ (add-before 'configure 'disable-pthreads
+ (lambda _
+ (substitute* "Configure"
+ (("^libswanted=(.*)pthread" _ before)
+ (string-append "libswanted=" before)))))))
+ ;; Do not configure with '-Dusethreads' since pthread
+ ;; support is missing.
+ ((#:configure-flags configure-flags)
+ #~(delete "-Dusethreads"
+ #$configure-flags)))))))
(define m4-boot0
(package