aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-19 23:41:13 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-19 23:55:43 +0100
commit1d56a2450964a6681f07596feb674d661509e334 (patch)
treeccd110cb05e7b8ed5bdb3dfb6941a7896bdaa418 /gnu
parent5c10649a50dd91f5ece816d949e4a751e8ba3777 (diff)
downloadguix-1d56a2450964a6681f07596feb674d661509e334.tar.gz
guix-1d56a2450964a6681f07596feb674d661509e334.zip
gnu: Add r-modstrings.
* gnu/packages/bioconductor.scm (r-modstrings): New variable. Change-Id: Ia61816213a7d128ab50a9ae2b2c8879e6ac00499
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d46c86db13..b1cd1f22cd 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -9082,6 +9082,43 @@ It has function interfaces for:
@end itemize")
(license license:expat)))
+(define-public r-modstrings
+ (package
+ (name "r-modstrings")
+ (version "1.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "Modstrings" version))
+ (sha256
+ (base32 "1jjawwkvdx02ss2vw4ah2b8psgxr01z6r1rkr2pnkmrp2ma7ygks"))))
+ (properties `((upstream-name . "Modstrings")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biocgenerics
+ r-biostrings
+ r-crayon
+ r-genomicranges
+ r-iranges
+ r-s4vectors
+ r-stringi
+ r-stringr
+ r-xvector))
+ (native-inputs (list r-knitr))
+ (home-page "https://bioconductor.org/packages/Modstrings")
+ (synopsis "Working with modified nucleotide sequences")
+ (description
+ "Representing nucleotide modifications in a nucleotide sequence is
+usually done via special characters from a number of sources. This represents
+a challenge to work with in R and the Biostrings package. The Modstrings
+package implements this functionallity for RNA and DNA sequences containing
+modified nucleotides by translating the character internally in order to work
+with the infrastructure of the Biostrings package. For this the
+@code{ModRNAString} and @code{ModDNAString} classes and derivates and
+functions to construct and modify these objects despite the encoding issues
+are implemenented. In addition the conversion from sequences to list like
+location information (and the reverse operation) is implemented as well.")
+ (license license:artistic2.0)))
+
(define-public r-motifrg
(package
(name "r-motifrg")