aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-21 10:34:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-21 11:08:13 +0100
commit1d00a9edffc3795bdbaf53a69edb6f98368e1ccf (patch)
tree17edf66e9dcbbecc14e701bbe50211a013b228d6 /gnu
parent0afe456973e8d5d51ea23c41579b94bde99d08d8 (diff)
downloadguix-1d00a9edffc3795bdbaf53a69edb6f98368e1ccf.tar.gz
guix-1d00a9edffc3795bdbaf53a69edb6f98368e1ccf.zip
gnu: Add r-protgear.
* gnu/packages/bioconductor.scm (r-protgear): New variable. Change-Id: Ic6d5cae65d4f76df4488ee2462071ba68b50c184
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm62
1 files changed, 62 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index f3419900f5..55cfc9facf 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -9980,6 +9980,68 @@ data and detection of regions with abnormal copy number within each parental
chromosome. Both tumor-normal paired and tumor-only analyses are supported.")
(license license:gpl2+)))
+(define-public r-protgear
+ (package
+ (name "r-protgear")
+ (version "1.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "protGear" version))
+ (sha256
+ (base32 "0r8md32vxjzarjldr9vsh3k0ms4zgqm9c7pp2flanbyinnqlfnxv"))))
+ (properties `((upstream-name . "protGear")))
+ (build-system r-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ ;; Needed by styler for writing to caches.
+ (add-after 'unpack 'set-HOME
+ (lambda _ (setenv "HOME" "/tmp"))))))
+ (propagated-inputs (list r-biobase
+ r-data-table
+ r-dplyr
+ r-factoextra
+ r-factominer
+ r-flexdashboard
+ r-genefilter
+ r-ggally
+ r-ggplot2
+ r-ggpubr
+ r-gtools
+ r-htmltools
+ r-kendall
+ r-knitr
+ r-limma
+ r-magrittr
+ r-mass
+ r-pheatmap
+ r-plotly
+ r-plyr
+ r-purrr
+ r-readr
+ r-remotes
+ r-rlang
+ r-rmarkdown
+ r-shiny
+ r-shinydashboard
+ r-styler
+ r-tibble
+ r-tidyr
+ r-vsn))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/Keniajin/protGear")
+ (synopsis
+ "Protein micro array data management and interactive visualization")
+ (description
+ "This package provides a generic three-step pre-processing package for
+protein microarray data. This package contains different data pre-processing
+procedures to allow comparison of their performance. These steps are
+background correction, the coefficient of variation (CV) based filtering,
+batch correction and normalization.")
+ (license license:gpl3)))
+
(define-public r-protgenerics
(package
(name "r-protgenerics")