aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDominik Delgado Steuter <dds@disroot.org>2023-05-20 15:49:13 +0200
committerLudovic Courtès <ludo@gnu.org>2023-05-25 12:51:16 +0200
commit1af79a0615094ba0d86f4c5580481ed8cd181cd9 (patch)
tree1ce4a5e41364d2645d64bbb1ae411fb0b2fcb13c /gnu
parentca5696b1a3562f5d908010454baddb3006d4ac97 (diff)
downloadguix-1af79a0615094ba0d86f4c5580481ed8cd181cd9.tar.gz
guix-1af79a0615094ba0d86f4c5580481ed8cd181cd9.zip
gnu: yt-dlp: Fix substitution for ffmpeg path.
The old expression did not work; ffmpeg was not found when using the --add-metadata flag. * gnu/packages/video.scm (yt-dlp) [arguments]: Adjust substitution in custom 'default-to-the-ffmpeg-input phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 40133bfbd4..ab19c2dd8c 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -64,6 +64,7 @@
;;; Copyright © 2022 Chadwain Holness <chadwainholness@gmail.com>
;;; Copyright © 2022 Andy Tai <atai@atai.org>
;;; Copyright © 2023 Ott Joon <oj@vern.cc>
+;;; Copyright © 2023 Dominik Delgado Steuter <dds@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2570,10 +2571,13 @@ YouTube.com and many more sites.")
#~(modify-phases #$phases
;; See the comment for the corresponding phase in youtube-dl.
(replace 'default-to-the-ffmpeg-input
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
(substitute* "yt_dlp/postprocessor/ffmpeg.py"
- (("\\.get_param\\('ffmpeg_location'\\)" match)
- (format #f "~a or '~a'" match (which "ffmpeg"))))))
+ (("location = self.get_param(.*)$")
+ (string-append
+ "location = '"
+ (dirname (search-input-file inputs "bin/ffmpeg"))
+ "'\n")))))
(replace 'build-generated-files
(lambda* (#:key inputs #:allow-other-keys)
(if (assoc-ref inputs "pandoc")