aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-09-18 14:12:15 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-11-28 11:04:20 +0200
commit1ae35ea08cd8a4c7b88bb086bd4c731560b5dded (patch)
treefee8cd3ddece3124be2bec44de50ab69f572d857 /gnu
parentf53b94bb0e7ca1be08cc62ad8c4fdb914912a0ed (diff)
downloadguix-1ae35ea08cd8a4c7b88bb086bd4c731560b5dded.tar.gz
guix-1ae35ea08cd8a4c7b88bb086bd4c731560b5dded.zip
gnu: Add rust-glib-sys-0.19.
* gnu/packages/crates-gtk.scm (rust-glib-sys-0.19): New variable. (rust-glib-sys-0.18): Inherit from rust-glib-sys-0.19. Change-Id: Ia3a63311b85e98459a5c528a8578cc0cd5e41ecc
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-gtk.scm37
1 files changed, 29 insertions, 8 deletions
diff --git a/gnu/packages/crates-gtk.scm b/gnu/packages/crates-gtk.scm
index f0ec651882..552b13d785 100644
--- a/gnu/packages/crates-gtk.scm
+++ b/gnu/packages/crates-gtk.scm
@@ -1948,8 +1948,36 @@
("rust-quote" ,rust-quote-1)
("rust-syn" ,rust-syn-1))))))
+(define-public rust-glib-sys-0.19
+ (package
+ (name "rust-glib-sys")
+ (version "0.19.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "glib-sys" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "19f4q8x77vd7c1d9ikw492yskq5kpd7k04qb8xnh1c427a6w2baw"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(;; XXX: Tests are sensitive to the version of glib, even though
+ ;; the library supports a wide range. Skip for now.
+ #:tests? #f
+ #:cargo-inputs (("rust-libc" ,rust-libc-0.2)
+ ("rust-system-deps" ,rust-system-deps-6))
+ #:cargo-development-inputs (("rust-shell-words" ,rust-shell-words-1)
+ ("rust-tempfile" ,rust-tempfile-3))))
+ (native-inputs (list pkg-config))
+ (inputs (list glib))
+ (home-page "https://gtk-rs.org/")
+ (synopsis "FFI bindings to libglib-2.0")
+ (description "This package provides FFI bindings to libglib-2.0.")
+ (license license:expat)))
+
(define-public rust-glib-sys-0.18
(package
+ (inherit rust-glib-sys-0.19)
(name "rust-glib-sys")
(version "0.18.1")
(source
@@ -1959,7 +1987,6 @@
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "164qhsfmlzd5mhyxs8123jzbdfldwxbikfpq5cysj3lddbmy4g06"))))
- (build-system cargo-build-system)
(arguments
`(;; XXX: Tests are sensitive to the version of glib, even though
;; the library supports a wide range. Skip for now.
@@ -1969,13 +1996,7 @@
("rust-system-deps" ,rust-system-deps-6))
#:cargo-development-inputs
(("rust-shell-words" ,rust-shell-words-1)
- ("rust-tempfile" ,rust-tempfile-3))))
- (native-inputs (list pkg-config))
- (inputs (list glib))
- (home-page "https://gtk-rs.org/")
- (synopsis "FFI bindings to libglib-2.0")
- (description "This package provides FFI bindings to libglib-2.0.")
- (license license:expat)))
+ ("rust-tempfile" ,rust-tempfile-3))))))
(define-public rust-glib-sys-0.17
(package