aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-12-13 20:58:33 +0100
committerVagrant Cascadian <vagrant@debian.org>2024-12-18 14:25:03 -0800
commit1a62f687e504c67f26693f3bc60a90e503ab4ea9 (patch)
tree2e2d8f223cd9d5aa8718b7391eb28400de698121 /gnu
parent56c6466887a3fdca0bc407418f807448a58e35d2 (diff)
downloadguix-1a62f687e504c67f26693f3bc60a90e503ab4ea9.tar.gz
guix-1a62f687e504c67f26693f3bc60a90e503ab4ea9.zip
gnu: bootloaders: u-boot-sandbox: Reformat.
* gnu/packages/bootloaders.scm (u-boot-sandbox): Wrap at 72 columns. Change-Id: I440c05b369c0be1437a3174e055efeeda8e5fe01 Signed-off-by: Vagrant Cascadian <vagrant@debian.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bootloaders.scm55
1 files changed, 28 insertions, 27 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 4426da6872..3122a185dd 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -1319,34 +1319,35 @@ partition."))
(make-u-boot-package "qemu-riscv64_smode" "riscv64-linux-gnu"))
(define-public u-boot-sandbox
- (let ((base (make-u-boot-package
- "sandbox" #f ;build for the native system
- ;; These disabled features require OpenSSL, which is
- ;; incompatible with the GPLv2-only parts of U-boot.
- #:configs (map (cut string-append "# CONFIG_" <> " is not set")
- '("FIT_CIPHER"))
- #:append-description
- "The sandbox configuration of U-Boot provides a
-@command{u-boot} command that runs as a normal user space application. It can
-be used to test the functionality of U-Boot interactively without having to
-deploy to an actual target device. @xref{Sandbox<6>,,,u-boot, The U-Boot
+ (define base
+ (make-u-boot-package
+ "sandbox" #f ;build for the native system
+ ;; These disabled features require OpenSSL, which is
+ ;; incompatible with the GPLv2-only parts of U-boot.
+ #:configs (map (cut string-append "# CONFIG_" <> " is not set")
+ '("FIT_CIPHER"))
+ #:append-description
+ "The sandbox configuration of U-Boot provides a @command{u-boot}
+command that runs as a normal user space application. It can be used to
+test the functionality of U-Boot interactively without having to deploy
+to an actual target device. @xref{Sandbox<6>,,,u-boot, The U-Boot
Documentation} for more information (for example by running @samp{info
-\"(u-boot) Sandbox<6>\"}).")))
- (package
- (inherit base)
- (arguments
- (substitute-keyword-arguments (package-arguments base)
- ((#:phases phases '%standard-phases)
- #~(modify-phases #$phases
- (add-after 'install 'symlink-u-boot-command
- (lambda* (#:key outputs #:allow-other-keys)
- ;; For ease of discovery.
- (mkdir (string-append #$output "/bin"))
- (symlink (search-input-file outputs "libexec/u-boot")
- (string-append #$output "/bin/u-boot"))))))))
- ;; cert-to-efi-sig-list from efitools creates the EFI capsule ESL.
- (inputs (modify-inputs (package-inputs base)
- (append efitools sdl2))))))
+\"(u-boot) Sandbox<6>\"})."))
+ (package
+ (inherit base)
+ (arguments
+ (substitute-keyword-arguments (package-arguments base)
+ ((#:phases phases '%standard-phases)
+ #~(modify-phases #$phases
+ (add-after 'install 'symlink-u-boot-command
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; For ease of discovery.
+ (mkdir (string-append #$output "/bin"))
+ (symlink (search-input-file outputs "libexec/u-boot")
+ (string-append #$output "/bin/u-boot"))))))))
+ ;; cert-to-efi-sig-list from efitools creates the EFI capsule ESL.
+ (inputs (modify-inputs (package-inputs base)
+ (append efitools sdl2)))))
(define-public u-boot-sifive-unleashed
(let ((base (make-u-boot-package "sifive_unleashed" "riscv64-linux-gnu")))