aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-18 12:57:35 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:54 -0400
commit1a564cf1471267894c3360e3a5bf0296be01b75d (patch)
tree9c99eb5af34c5688dc49fa23e54b3213f74ffd79 /gnu
parent3f9eafbedd5a9c833aed1954f8ad18b3a7699222 (diff)
downloadguix-1a564cf1471267894c3360e3a5bf0296be01b75d.tar.gz
guix-1a564cf1471267894c3360e3a5bf0296be01b75d.zip
gnu: Add python-jupyterlab-server.
* gnu/packages/jupyter.scm (python-jupyterlab-server): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/jupyter.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 9bda6e23bd..82e7be6792 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -215,6 +215,56 @@ alternative Python kernel for Jupyter.")
the JupyterLab CSS variables.")
(license license:bsd-3)))
+(define-public python-jupyterlab-server
+ (package
+ (name "python-jupyterlab-server")
+ (version "2.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jupyterlab_server" version))
+ (sha256
+ (base32 "1gxbfa5s0v4z0v8kagkm2bz8hlli5pwhr89y68w5kxcrqfsg9q00"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "-c" "/dev/null" "tests"
+ ;; XXX: These tests appear to fail due to the lack of
+ ;; locales.
+ "-k" "not locale and not language")))))))
+ (propagated-inputs
+ (list python-babel
+ python-entrypoints
+ python-importlib-metadata ;TODO: remove after Python >= 3.10
+ python-jinja2
+ python-json5
+ python-jsonschema
+ python-jupyter-server
+ python-packaging
+ python-requests))
+ (native-inputs
+ (list python-ipykernel
+ python-jupyter-server
+ python-openapi-core
+ python-openapi-spec-validator
+ python-pytest
+ python-pytest-console-scripts
+ python-pytest-tornasync
+ python-ruamel.yaml
+ python-strict-rfc3339))
+ (home-page "https://jupyter.org")
+ (synopsis "Server components for JupyterLab applications")
+ (description "JupyterLab Server sits between JupyterLab and Jupyter
+Server, and provides a set of REST API handlers and utilities that are used by
+JupyterLab. It is a separate project in order to accommodate creating
+JupyterLab-like applications from a more limited scope.")
+ (license license:bsd-3)))
+
(define-public python-jupyter-packaging
(package
(name "python-jupyter-packaging")
ackages/php.scm (php)[inputs]: Replace GD-2.2.5 with GD. Marius Bakke 2017-08-31gnu: gd: Replace with 2.2.5....Fixes CVE-2017-6362 and CVE-2017-7890. * gnu/packages/gd.scm (gd)[replacement]: New field. (gd-2.2.5): New variable. * gnu/packages/php.scm (gd-for-php): Remove variable (php)[inputs]: Replace GD-FOR-PHP with GD-2.2.5. * gnu/packages/patches/gd-CVE-2017-7890.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Marius Bakke 2017-07-27gnu: perl-gd-securityimage: Fix build with Perl 5.26.0....* gnu/packages/gd.scm (perl-gd-securityimage)[arguments]: Set PERL_USE_UNSAFE_INC in new 'set-env' phase. Leo Famulari 2017-05-02gnu: Avoid circular dependencies by Perl license....* guix/licenses.scm (perl-license): New variable. * gnu/packages/bioinformatics.scm: Change (package-license perl) to perl-license. * gnu/packages/compression.scm: Same. * gnu/packages/databases.scm: Same. * gnu/packages/gd.scm: Same. * gnu/packages/language.scm: Same. * gnu/packages/libevent.scm: Same. * gnu/packages/mail.scm: Same. * gnu/packages/messaging.scm: Same. * gnu/packages/ncurses.scm: Same. * gnu/packages/networking.scm: Same. * gnu/packages/photo.scm: Same. * gnu/packages/tcl.scm: Same. * gnu/packages/tex.scm: Same. * gnu/packages/tls.scm: Same. * gnu/packages/web.scm: Same. * gnu/packages/wm.scm: Same. * gnu/packages/xml.scm: Same. * gnu/packages/xorg.scm: Same. * gnu/packages/zip.scm: Same. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Petter 2017-03-03gnu: gd: Fix an issue with XBM decoding....* gnu/packages/patches/gd-php-73968-Fix-109-XBM-reading.patch: New file. * gnu/local.scm (dist_patch_DATA): Add it. * gnu/packages/gd.scm (gd)[source]: Use it. Signed-off-by: Leo Famulari <leo@famulari.name> Julien Lepiller 2017-03-01gnu: gd: Fix test failure on aarch64....* gnu/packages/gd.scm (gd)[arguments]: Add make-flag -ffp-contract=off to work around upstream bug 278. Efraim Flashner 2017-02-26gnu: gd: Fix test failure with FreeType 2.7....* gnu/packages/patches/gd-freetype-test-failure.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gd.scm (gd)[source]: Use it. Leo Famulari 2017-01-25gnu: gd: Incorporate grafted changes....* gnu/packages/gd.scm (gd)[replacement]: Remove field. [source]: Update to 2.2.4. Remove patches 'gd-CVE-2016-7568.patch' and 'gd-CVE-2016-8670.patch'. [arguments]: New field. (gd-2.2.4): Remove variable. * gnu/packages/patches/gd-CVE-2016-7568.patch, gnu/packages/patches/gd-CVE-2016-8670.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. Leo Famulari 2017-01-20gnu: gd: Fix source URL....This is a followup to 3f0603ea653cefa9ff728c2637d3cd0d778b3602. * gnu/packages/gd.scm (gd-2.2.4)[source]: Fix URL. Marius Bakke 2017-01-20gnu: gd: Replace with gd-2.2.4 [fixes CVE-2016-{6912,9317} and others]....'CHANGELOG.md' in the development repository lists several fixed bugs with potential security implications: https://github.com/libgd/libgd/blob/gd-2.2.4/CHANGELOG.md * gnu/packages/gd.scm (gd)[replacement]: New field. (gd-2.2.4): New variable. Leo Famulari