aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-07 17:08:13 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-13 14:16:27 +0000
commit1996575a7e30bc1c1bfd19840879f530869bec4e (patch)
treee20fedd061ff16731090961ef66f38ba6d8790cf /gnu
parent5a77f2ee541b6a738fcf0dae762884825cd26d50 (diff)
downloadguix-1996575a7e30bc1c1bfd19840879f530869bec4e.tar.gz
guix-1996575a7e30bc1c1bfd19840879f530869bec4e.zip
gnu: Add (gnu packages golang-compression) module.
* gnu/packages/golang-compression.scm: New file. * gnu/local.mk: Add to gnu/packages/golang-compression.scm scope. Change-Id: I1c68a3f6f9b3d6a316cba560b7fc81e707376417
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/golang-compression.scm37
2 files changed, 38 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 53c7e369bd..5683dbf6de 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -310,6 +310,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/golang.scm \
%D%/packages/golang-build.scm \
%D%/packages/golang-check.scm \
+ %D%/packages/golang-compression.scm \
%D%/packages/golang-crypto.scm \
%D%/packages/golang-web.scm \
%D%/packages/golang-xyz.scm \
diff --git a/gnu/packages/golang-compression.scm b/gnu/packages/golang-compression.scm
new file mode 100644
index 0000000000..268cd16e30
--- /dev/null
+++ b/gnu/packages/golang-compression.scm
@@ -0,0 +1,37 @@
+;;; GNU Guix --- Functional package management for GNU
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages golang-compression)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system go)
+ #:use-module (guix gexp)
+ #:use-module (guix git-download)
+ #:use-module (guix packages)
+ #:use-module (guix utils)
+ #:use-module (gnu packages))
+
+;;; Commentary:
+;;;
+;;; Please: Try to add new module packages in alphabetic order.
+;;;
+;;; Code:
+
+;;;
+;;; Avoid adding new packages to the end of this file. To reduce the chances
+;;; of a merge conflict, place them above by existing packages with similar
+;;; functionality or similar names.
+;;;