aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-09-15 16:02:41 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-09-15 16:11:35 +0200
commit16ffcce3cdbae2bf8458e8b0bbb68d135099b1b3 (patch)
tree5265178fe7660da1e78b3127fcfc2756f0076c1d /gnu
parent4d8a3251c590140782d340f7b2bc6c238c75c965 (diff)
downloadguix-16ffcce3cdbae2bf8458e8b0bbb68d135099b1b3.tar.gz
guix-16ffcce3cdbae2bf8458e8b0bbb68d135099b1b3.zip
gnu: emacs-volatile-highlights: Fix build.
* gnu/packages/emacs-xyz.scm (emacs-volatile-highlights): Use git tag instead of commit hash. Change-Id: I2977b6c7db9826e79278548a7b7f97c8099df0c3
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 10 insertions, 12 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c09d8e1e92..5240a4453e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -39947,20 +39947,18 @@ Validator service and displays the results in a buffer in Compilation mode.")
(license license:gpl3+))))
(define-public emacs-volatile-highlights
- ;; XXX: Upstream does not tag releases. Commit below matches version bump.
- (let ((commit "9a20091f0ce7fc0a6b3e641a6a46d5f3ac4d8392"))
- (package
+ (package
(name "emacs-volatile-highlights")
(version "1.16")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "http://github.com/k-talo/volatile-highlights.el")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0rlqwj6whxbvzgkf78d8arjva49aphj4bd2wkpv8djykcmi8nf6m"))))
+ (method git-fetch)
+ (uri (git-reference
+ (url "http://github.com/k-talo/volatile-highlights.el")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1dsa6769lphyyv7yg92vkkpk395w52q4m7hdn8xy7s6lh5c6a955"))))
(build-system emacs-build-system)
(home-page "http://github.com/k-talo/volatile-highlights.el")
(synopsis "Emacs minor mode for visual feedback on some operations")
@@ -39968,7 +39966,7 @@ Validator service and displays the results in a buffer in Compilation mode.")
some operations by highlighting portions relating to the operations. All of
highlights made by this library will be removed when any new operation is
executed.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-global-tags
(let ((commit "06db25d91cc8bfb5e24e02adc04de1226c7e742d")