aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-08 08:37:50 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:18 -0400
commit1614217e9125905864995370eb5180de0358d166 (patch)
treef9c74ca1d482306f3a16120a9199c261c785e099 /gnu
parent39f41cf93a87a94695f83372e590efab3b712230 (diff)
downloadguix-1614217e9125905864995370eb5180de0358d166.tar.gz
guix-1614217e9125905864995370eb5180de0358d166.zip
gnu: Add ruby-simplecov-lcov.
* gnu/packages/ruby.scm (ruby-simplecov-lcov): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 7911630702..ee3e5da702 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3459,6 +3459,33 @@ suites.")
(home-page "https://github.com/simplecov-ruby/simplecov")
(license license:expat)))
+(define-public ruby-simplecov-lcov
+ (package
+ (name "ruby-simplecov-lcov")
+ (version "0.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "simplecov-lcov" version))
+ (sha256
+ (base32
+ "1h8kswnshgb9zidvc88f4zjy4gflgz3854sx9wrw8ppgnwfg6581"))))
+ (build-system ruby-build-system)
+ ;; The test suite fails half of its tests; it seems to rely on older
+ ;; versions of simplecov, rspec, possibly others (see:
+ ;; https://github.com/fortissimo1997/simplecov-lcov/issues/29).
+ (arguments (list #:tests? #f
+ #:test-target "spec"))
+ (native-inputs
+ (list ruby-activesupport
+ ruby-coveralls
+ ruby-rspec
+ ruby-simplecov))
+ (synopsis "SimpleCov formatter to generate a lcov style coverage")
+ (description "This package provides a SimpleCov formatter to generate a
+lcov-style coverage report.")
+ (home-page "https://github.com/fortissimo1997/simplecov-lcov")
+ (license license:expat)))
+
(define-public ruby-useragent
(package
(name "ruby-useragent")