aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-08-11 00:09:52 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-21 12:02:03 +0100
commit158ee2c76aa0d859b7487aee907c2d92d116671f (patch)
tree1a5b0bea0bfd4934292ddd3e9ec3344623f0af60 /gnu
parent127592bc0fd7f5deb79ea05dd9e7d3bfdb3c2a1d (diff)
downloadguix-158ee2c76aa0d859b7487aee907c2d92d116671f.tar.gz
guix-158ee2c76aa0d859b7487aee907c2d92d116671f.zip
gnu: Add go-github-com-ipfs-go-verifcid.
* gnu/packages/ipfs.scm (go-github-com-ipfs-go-verifcid): New variable. Change-Id: I30b800dc0575ed3d7b208a1860c305911e1944d2 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ipfs.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index ccf5728e4f..bbccab37cd 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -547,6 +547,40 @@ order to be a part of the @acronym{IPLD, InterPlanetary Linked Data} merkle-fore
and @code{go-ipld-format} legacy interface.")
(license (list license:expat license:asl2.0))))
+;; XXX: This repository has been archived by the owner on Jun 20, 2023. It is
+;; now read-only. We highly recommend switching to the maintained version at
+;; https://github.com/ipfs/boxo/tree/main/verifcid. It's still in use by some
+;; dependencies chain for unbundled inputs in Kubo.
+(define-public go-github-com-ipfs-go-verifcid
+ (package
+ (name "go-github-com-ipfs-go-verifcid")
+ (version "0.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-verifcid")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05i6wp2nln0mlr1pivmva7j6bwa09k7jl04acx1lw65h4d9nxsjm"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ipfs/go-verifcid"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-ipfs-go-cid go-github-com-multiformats-go-multihash))
+ (home-page "https://github.com/ipfs/go-verifcid")
+ (synopsis "CID security code")
+ (description
+ "@code{go-verifcid} provides @url{https://github.com/ipld/cid, CID} security
+code prior to it getting merged into @code{go-cid}.")
+ ;; This library is dual-licensed under Apache 2.0 and MIT terms:
+ ;; LICENSE-MIT and LICENSE-APACHE.
+ (license (list license:expat license:asl2.0))))
+
(define-public go-github-com-ipld-go-codec-dagpb
(package
(name "go-github-com-ipld-go-codec-dagpb")