aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-03-17 19:19:18 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-21 21:12:09 -0400
commit151be9ec766f82ef2439ce2cc95e04b7d0de3c91 (patch)
tree13c111f3863d0d08276a6dcccf533ff926152a31 /gnu
parent61e17e2f0dfd6f6ce224bfea63a1e173fed851a1 (diff)
downloadguix-151be9ec766f82ef2439ce2cc95e04b7d0de3c91.tar.gz
guix-151be9ec766f82ef2439ce2cc95e04b7d0de3c91.zip
gnu: Add python-pluggy-next.
* gnu/packages/python-xyz.scm (python-pluggy-next): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9d086136d0..f0f003cc8b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15389,6 +15389,19 @@ Pytest but stripped of Pytest specific details.")
(home-page "https://pypi.org/project/pluggy/")
(license license:expat)))
+;;; TODO: Make this the default python-pluggy in the next rebuild cycle.
+(define-public python-pluggy-next
+ (package
+ (inherit python-pluggy)
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pluggy" version))
+ (sha256
+ (base32
+ "0n8iadlas2z1b4h0fc73b043c7iwfvx9rgvqm1azjmffmhxkf922"))))))
+
(define-public python-plumbum
(package
(name "python-plumbum")