aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:32:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:01 +0200
commit151535996297ca392954affc993e8ade6b2451c7 (patch)
tree701bdde77a9df85f4848a35b3d2db9e788b37a8a /gnu
parent8351f482bd198b93efd22338ef3c06a78e4e2239 (diff)
downloadguix-151535996297ca392954affc993e8ade6b2451c7.tar.gz
guix-151535996297ca392954affc993e8ade6b2451c7.zip
gnu: Add texlive-ryethesis.
* gnu/packages/tex.scm (texlive-ryethesis): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6953e2e157..c672f16c8f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -26600,6 +26600,27 @@ university.")
School of Graduate Studies (SGS) theses.")
(license license:asl2.0)))
+(define-public texlive-ryethesis
+ (package
+ (name "texlive-ryethesis")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/ryethesis/"
+ "source/latex/ryethesis/"
+ "tex/latex/ryethesis/")
+ (base32
+ "1xjzl1ng0nbcakiasi6sfbkannfipcfv96crq6y6cb7p7l707wg7")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/ryethesis")
+ (synopsis "Class for Ryerson Unversity Graduate School requirements")
+ (description
+ "The class offers support for formatting a thesis, dissertation or
+project according to Ryerson University's School of Graduate Studies thesis
+formatting regulations.")
+ (license license:lppl1.3+)))
+
(define-public texlive-sankey
(package
(name "texlive-sankey")