aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-16 00:08:37 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:57 +0200
commit13c3ec8ba7938483782ae6190ad59f1bd7b76e14 (patch)
treec184d317a64097b5026d78b489a010f54b06385f /gnu
parentddaeb4b09f4bab5485a6874e9b152d727eaa0607 (diff)
downloadguix-13c3ec8ba7938483782ae6190ad59f1bd7b76e14.tar.gz
guix-13c3ec8ba7938483782ae6190ad59f1bd7b76e14.zip
gnu: texlive-alphalph: Refresh package definition.
* gnu/packages/tex.scm (texlive-alphalph): Remove SIMPLE-TEXLIVE-PACKAGE call.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm49
1 files changed, 23 insertions, 26 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bc342002ad..e1d0f23f88 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -692,32 +692,29 @@ executables. It is maintained as a part of TeX Live.")))
(deprecated-package (symbol->string 'old-name) name)))
(define-public texlive-alphalph
- (let ((template (simple-texlive-package
- "texlive-alphalph"
- (list "doc/latex/alphalph/"
- "source/latex/alphalph/"
- "tex/generic/alphalph/")
- (base32
- "0ap59hmg0brg2wlh3bl77jxfxrk7hphhdal8cr05mby9bw35gffy"))))
- (package
- (inherit template)
- (outputs '("out" "doc"))
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:build-targets _ '())
- #~(list "alphalph.dtx"))))
- (propagated-inputs
- (list texlive-intcalc texlive-infwarerr))
- (home-page "https://ctan.org/pkg/alphalph")
- (synopsis "Convert numbers to letters")
- (description
- "This package provides commands @code{\\alphalph} and
-@code{\\AlphAlph}. They are like @code{\\number} but the expansion
-consists of lowercase and uppercase letters respectively (1 to a, 26 to
-z, 27 to aa, 52 to zz, 53 to ba, 702 to zz, 703 to aaa, etc.).
-Alphalph's commands can be used as a replacement for LaTeX's
-@code{\\@@alph} and @code{\\@@Alph} macros.")
- (license license:lppl1.3c+))))
+ (package
+ (name "texlive-alphalph")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/alphalph/"
+ "source/latex/alphalph/"
+ "tex/generic/alphalph/")
+ (base32
+ "0ap59hmg0brg2wlh3bl77jxfxrk7hphhdal8cr05mby9bw35gffy")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-intcalc texlive-infwarerr))
+ (home-page "https://ctan.org/pkg/alphalph")
+ (synopsis "Convert numbers to letters")
+ (description
+ "This package provides commands @code{\\alphalph} and @code{\\AlphAlph}.
+They are like @code{\\number} but the expansion consists of lowercase and
+uppercase letters respectively (1 to a, 26 to z, 27 to aa, 52 to zz, 53 to ba,
+702 to zz, 703 to aaa, etc.). Alphalph's commands can be used as
+a replacement for LaTeX's @code{\\@@alph} and @code{\\@@Alph} macros.")
+ (license license:lppl1.3c+)))
(define texlive-docstrip
(package