aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 23:46:24 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:04 +0000
commit11f6c41d10c4b024a97396c0b530ae5bd57168a3 (patch)
tree87683857ea844d033335f876fb66a5753aec4bfa /gnu
parent42d10bd20160165c5ad89216bdc1b3f6fbff7077 (diff)
downloadguix-11f6c41d10c4b024a97396c0b530ae5bd57168a3.tar.gz
guix-11f6c41d10c4b024a97396c0b530ae5bd57168a3.zip
gnu: go-github-com-protonmail-go-crypto: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-protonmail-go-crypto): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. Change-Id: I8ab594fcb5b5b7eeec777a177eb7541ed49dba90
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-crypto.scm31
-rw-r--r--gnu/packages/golang.scm31
2 files changed, 31 insertions, 31 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index d1d6122f95..417dbc34f6 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -368,6 +368,37 @@ the Go standard library's TLS 1.3 implementation.")
QUIC. For Go 1.20.")
(license license:expat)))
+(define-public go-github-com-protonmail-go-crypto
+ (package
+ (name "go-github-com-protonmail-go-crypto")
+ (version "0.0.0-20220623141421-5afb4c282135")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ProtonMail/go-crypto")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05qxdbn8wdk901z5kw2r3jdrag58nxlcsy0p8xd6rq0d71sw94wy"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/ProtonMail/go-crypto"
+ #:tests? #f ; Source-only package.
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Source-only package.
+ (delete 'build))))
+ (propagated-inputs
+ (list go-golang-org-x-crypto))
+ (home-page "https://github.com/ProtonMail/go-crypto")
+ (synopsis "Fork of x/crypto with up-to-date OpenPGP implementation")
+ (description "This package provides cryptography for Go. This version of
+the package is a fork that adds a more up-to-date OpenPGP implementation. It
+is completely backwards compatible with @code{golang.org/x/crypto}, the
+official package.")
+ (license license:bsd-3)))
+
(define-public go-github-com-refraction-networking-utls
(package
(name "go-github-com-refraction-networking-utls")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2b80b2e9be..a0e50ef8d3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3699,37 +3699,6 @@ developed by the Go team. It provides IDE features to any LSP-compatible
editor.")
(license license:bsd-3)))
-(define-public go-github-com-protonmail-go-crypto
- (package
- (name "go-github-com-protonmail-go-crypto")
- (version "0.0.0-20220623141421-5afb4c282135")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ProtonMail/go-crypto")
- (commit (go-version->git-ref version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "05qxdbn8wdk901z5kw2r3jdrag58nxlcsy0p8xd6rq0d71sw94wy"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "github.com/ProtonMail/go-crypto"
- #:tests? #f ; Source-only package.
- #:phases
- #~(modify-phases %standard-phases
- ;; Source-only package.
- (delete 'build))))
- (propagated-inputs (list go-golang-org-x-crypto))
- (home-page "https://github.com/ProtonMail/go-crypto")
- (synopsis "Fork of x/crypto with up-to-date OpenPGP implementation")
- (description
- "This package provides cryptography for Go. This version of the
-package is a fork that adds a more up-to-date OpenPGP implementation.
-It is completely backwards compatible with @code{golang.org/x/crypto},
-the official package.")
- (license license:bsd-3)))
-
(define-public go-golang-org-x-net
(let ((commit "8e0e7d8d38f2b6d21d742845570dde2902d06a1d")
(revision "0"))