aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-06-23 13:48:55 +0000
committerRicardo Wurmus <rekado@elephly.net>2023-07-03 09:58:57 +0200
commit11651fbf7f1908351261dc6c9dd6a967acaabbc5 (patch)
tree58d2788af86bae5c6290bd481c1fbbc931aed521 /gnu
parent6398fa786032ad0919267019e260082354980635 (diff)
downloadguix-11651fbf7f1908351261dc6c9dd6a967acaabbc5.tar.gz
guix-11651fbf7f1908351261dc6c9dd6a967acaabbc5.zip
gnu: Add r-cellid.
* gnu/packages/bioconductor.scm (r-cellid): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 00701c4463..a566279441 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1436,6 +1436,51 @@ curated cell type labels, for use in procedures like automated annotation of
single-cell data or deconvolution of bulk RNA-seq.")
(license license:gpl3)))
+(define-public r-cellid
+ (package
+ (name "r-cellid")
+ (version "1.8.1")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "CelliD" version))
+ (sha256
+ (base32
+ "0vigvqjrlqbi5kviaj8qvyq3v8afgbc5pjrz7zmx2ckf4hdp0g03"))))
+ (properties `((upstream-name . "CelliD")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-data-table
+ r-biocparallel
+ r-fastmatch
+ r-fgsea
+ r-ggplot2
+ r-glue
+ r-irlba
+ r-matrix
+ r-matrixstats
+ r-pbapply
+ r-rcpp
+ r-rcpparmadillo
+ r-reticulate
+ r-rtsne
+ r-seurat
+ r-stringr
+ r-tictoc
+ r-singlecellexperiment
+ r-summarizedexperiment
+ r-umap))
+ (native-inputs (list r-knitr r-scater))
+ (home-page "https://bioconductor.org/packages/CelliD")
+ (synopsis
+ "Single cell gene signature extraction using multiple correspondence analysis")
+ (description
+ "CelliD is a clustering-free method for extracting per-cell gene
+signatures from scRNA-seq. CelliD allows unbiased cell identity recognition
+across different donors, tissues-of-origin, model organisms and single-cell
+omics protocols. The package can also be used to explore functional pathways
+enrichment in single cell data.")
+ (license license:gpl3)))
+
(define-public r-champdata
(package
(name "r-champdata")