aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-03 20:22:15 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:48 +0100
commit102069811f466ecea380d1501ad3adf8e51e2c8b (patch)
tree10e46afb7530a1cabca6868241dee17f674df8ee /gnu
parent5cbbce16f2e6c0fd0befe5d5141e5d807c908ae0 (diff)
downloadguix-102069811f466ecea380d1501ad3adf8e51e2c8b.tar.gz
guix-102069811f466ecea380d1501ad3adf8e51e2c8b.zip
gnu: go-golang-org-x-image: Fix indentation.
* gnu/packages/golang-build.scm (go-golang-org-x-image): Fix indentation. Change-Id: I558cf2c2edf918408bb4ff6c8605e27ba6145992
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-build.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 34adcf71e7..c1af557f2b 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -207,19 +207,19 @@ compile does not support generics.")
(file-name (git-file-name name version))
(sha256
(base32 "0d7zwdsg06km24vhx6dzk1w26wpi3yhx9jfkf9jnsp5chv5pzlw3"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "golang.org/x/image"
- ;; Source-only package
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'build))))
- (home-page "https://go.googlesource.com/image")
- (synopsis "Supplemental Go image libraries")
- (description "This package provides supplemental Go libraries for image
-processing.")
- (license license:bsd-3)))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "golang.org/x/image"
+ ;; Source-only package
+ #:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'build))))
+ (home-page "https://go.googlesource.com/image")
+ (synopsis "Supplemental Go image libraries")
+ (description
+ "This package provides supplemental Go libraries for image processing.")
+ (license license:bsd-3)))
(define-public go-golang-org-x-mod
(let ((commit "7c05a442b7c1d1a107879b4a090bb5a38d3774a1")
> Richard Sent 2024-06-04file-systems: Add host-to-ip nested function...* gnu/build/file-systems (mount-file-system): Split out getaddrinfo logic into a dedicated function, (host-to-ip) Change-Id: I522d70a10651ca79533a4fc60b96b884243a3526 Signed-off-by: Ludovic Courtès <ludo@gnu.org> Richard Sent 2024-05-29gnu: linux-libre: Enable Zstd compression of kernel modules....This brings the on disk size of the kernel from 164 MiB to 144 MiB, or about 12%. * gnu/packages/linux.scm (default-extra-linux-options) [version>=5.13]: Enable CONFIG_MODULE_COMPRESS_ZSTD, else CONFIG_MODULE_COMPRESS_GZIP. (make-linux-libre*) [phases] {set-environment}: Set ZSTD_CLEVEL environment variable to 19. [native-inputs]: Add zstd. * gnu/build/linux-modules.scm (module-regex): Add .zst to regexp. Update doc. (modinfo-section-contents): Extend support to Zstd compressed module. (dot-ko): Register the 'zstd compression type. (ensure-dot-ko, file-name->module-name, load-linux-module*) (module-name->file-name/guess, write-module-name-database) (write-module-alias-database, write-module-device-database): Update doc. (module-name-lookup): Also consider zstd-compressed modules. * gnu/installer.scm (installer-program): Add guile-zstd extension to gexp. * gnu/system/linux-initrd.scm (flat-linux-module-directory): Likewise. Decompress zstd-compressed modules for use in initrd. * guix/profiles.scm (linux-module-database): Add guile-zstd extension to gexp. Change-Id: Ide899dc5c58ea5033583b1a91a92c025fc8d901a Maxim Cournoyer