aboutsummaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:03:08 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:52 +0200
commit0ccfc27f5116b1b63480b2233301a497834bc5bb (patch)
treeb76afb2fbf837d65ff4a2bf8d96f71f058b4bbc8 /gnu
parent4055b198f1c28556c1faba97cf312ac663782881 (diff)
downloadguix-0ccfc27f5116b1b63480b2233301a497834bc5bb.tar.gz
guix-0ccfc27f5116b1b63480b2233301a497834bc5bb.zip
gnu: Add texlive-textfit.
* gnu/packages/tex.scm (texlive-textfit): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 87e8e6e964..49ea180852 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -97922,6 +97922,24 @@ acronyms to be presented as uppercase in text (useful for things like copying
and pasting from a PDF).")
(license (list license:lppl1.3+ license:cc-by-sa3.0))))
+(define-public texlive-textfit
+ (package
+ (name "texlive-textfit")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/textfit/" "source/latex/textfit/"
+ "tex/latex/textfit/")
+ (base32
+ "18rhvd8xh83xi7f7mvnqblmi45ws4pcr0vbs689s2ycdxfzfhfzr")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/textfit")
+ (synopsis "Fit text to a desired size")
+ (description
+ "This package fits text to a given width or height by scaling the font.")
+ (license license:lppl1.3+)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar